cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dbartnick
Level 3

Optionally install a Redistributable

I need to ask the user (if an outdated version of SQL Standard is detected) if they would like to install SQLExpress or update their SQL Standard. Is there a way of prompting the user for input before the redistributables are run?
Labels (1)
0 Kudos
3 Replies
Holger_G
Level 10

Check the 'The prerequisite may be optionally skipped by the user' checkbox at the Behavior setting of the prerequisite. That should do the job.
0 Kudos
dbartnick
Level 3

That does give the user the option to skip the prereq, but it doesn't give me the ability to do the following:
1) Only give the user the option to skip the prereq if SQL Std is detected.
2) Tell the user why they should or should not install SQL Express.

Any ideas?
0 Kudos
Holger_G
Level 10

1) Create multiple prerequisites for the same Prerequisite using different conditions. Would that be an option?
0 Kudos