cancel
Showing results for 
Search instead for 
Did you mean: 
Mortimer452
Pilgrim

Need help removing a busted InstallShield package

InstallShield 2015 Limited bundled with Studio 2013. My solution has multiple outputs, couple of Windows services and a windows app.

InstallShield, as you probably know, only deletes files that were included as part of the install when you run the uninstall. This tends to leave some "junk" behind sometimes, things like log files or temp folders your app may have created during its use.

I added a custom uninstall action to clean up the install directory using VBScript. Alas, my VBScript has an error in it, so now the uninstall blows up.
Now, I can't even get my app uninstalled to try a new setup package. What's the best way to lean up this mess?
Labels (1)
0 Kudos
3 Replies
rguggisberg
Active participant

Re: Need help removing a busted InstallShield package

You can try this at your own risk. Please back up the registry first!
Use REGEDIT and navigate to: (use Wow6432Node if 32 bit install package)
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield Uninstall Information
Under that look for {Product Code for your installation package}. Delete it.
Also delete the key under that named InstallShield_{Product Code for your installation package}.
Now delete all of the files installed by your installer.
That should do it.

Now you can see the beauty of doing this kind of testing on a virtual machine with a reasonably recent checkpopint. If you trash something (and this will happen again someday) you just revert the VM to the desired checkpoint and go.

Hope this gets you going.
0 Kudos
Highlighted
Mortimer452
Pilgrim

Re: Need help removing a busted InstallShield package

Thanks for the suggestion. Tried this but it didn't quite work - the product was removed from the "Add/remove programs" screen in Windows but my installer still detected it there, and tried to uninstall before re-installing the new version.

Found a great utility by Microsoft that took care of this, it's called MsiZap and comes with the Windows 7 SDK. Cleaned up everything else needed to make InstallShield think the program was uninstalled successfully, so I could fix my package and try again :)

Running this from the command-line will blast all the InstallShield registry entries, but does not delete files, so you'll have to do that manually:

msizap.exe T {your_product_code_here}
0 Kudos
Jamesbo
Pilgrim

Re: Need help removing a busted InstallShield package

There is also a microsoft "Fixit" button download for an executable for removing stuck entries in the ARP but I imagine it does just the same thing. you can search for it on MSDN (try "cannot uninstall from remove programs" or similar) I'm sorry I don't have link anymore.
0 Kudos