cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
ChopperCharles
Flexera beginner

NSIS prerequisite in an InstallShield project?

Jump to solution

Is it possible to package up an installer made with NSIS (NullSoft's installer) inside an InstallShield project? The NSIS installer (NPCap) is required for my software to operate. 

 

Thanks.

 

Charles.

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Flexera banna_k
Flexera

Re: NSIS prerequisite in an InstallShield project?

Jump to solution

Hi @ChopperCharles ,

You can specify the prerequisite build location to "Extract From Setup.exe" from the "Properties" dialog of your prerequisite. Select your prerequisite, the select the "Properties" from the context menu to change the build location.

Again do the same setting for the "InstallShield Prerequisites Location" under the Releases view setup.exe tab.

View solution in original post

0 Kudos
5 Replies
Flexera banna_k
Flexera

Re: NSIS prerequisite in an InstallShield project?

Jump to solution

Hi @ChopperCharles,

 

Ye, it is possible. you can create a prerequisite for your NSIS installer (NPCap). More information can be found at 

https://helpnet.flexerasoftware.com/installshield25helplib/helplibrary/CreatingPrereq.htm 

https://helpnet.flexerasoftware.com/installshield25helplib/helplibrary/SetupPrereqEditor.htm#ref-pre...

Then, you can select this newly created prerequisite from the Redistributables view in your InstallShield project. 

0 Kudos
simonblair
Pilgrim

Re: NSIS prerequisite in an InstallShield project?

Jump to solution

@banna_k wrote:

Hi @ChopperCharles,

 

Ye, it is possible. you can create a prerequisite for your NSIS installer (NPCap). More information can be found at 

https://helpnet.flexerasoftware.com/installshield25helplib/helplibrary/CreatingPrereq.htm 

https://helpnet.flexerasoftware.com/installshield25helplib/helplibrary/SetupPrereqEditor.htm#ref-pre... short life

Then, you can select this newly created prerequisite from the Redistributables view in your InstallShield project. 


Ok, that is clear now. Thank you for your answer.

0 Kudos
ChopperCharles
Flexera beginner

Re: NSIS prerequisite in an InstallShield project?

Jump to solution

I've tried doing as you suggest, but I cannot get the project to compile afterwards. I added the prerequisite, set the path to the installer executable, set it to local, and then clicked the checkbox for the prerequisite name under APPLICATION DATA->Redistributables. Doing so results in the error: "You have choosen to download the InstallShield prerequisite files for PRQ file MySetupPrerequisite.prq. This InstallShield prerequisite does not contain download information."

I have not "choosen" (this misspelling comes directly from InstallSheild) download at all. I specifically set it for local installation only, and gave it the path to the EXE. 

What am I missing here?

 

Charles.

0 Kudos
Flexera banna_k
Flexera

Re: NSIS prerequisite in an InstallShield project?

Jump to solution

Hi @ChopperCharles ,

You can specify the prerequisite build location to "Extract From Setup.exe" from the "Properties" dialog of your prerequisite. Select your prerequisite, the select the "Properties" from the context menu to change the build location.

Again do the same setting for the "InstallShield Prerequisites Location" under the Releases view setup.exe tab.

View solution in original post

0 Kudos
ChopperCharles
Flexera beginner

Re: NSIS prerequisite in an InstallShield project?

Jump to solution

The advice to check the Releases View is what fixed it for me. 

 

Media->Releases in the left pane, then under Releases->Build Setup  there are a number of entries in my project. Debug Setup, Release Setup, Debug MSI, and Release MSI. Click on each one of those, then click the "Setup.exe" tab. The second-to-last entry is "InstallShield Prerequisites Location". I set this to "Follow Individual Selections", as my installer also required "Microsoft .Net Framework 4.6.1 Web" in addition to the NPCAP installer.  (Make sure the .Net Framework 4.6.1 Web prerequesite needs to be set to "Download From The Web" in Application Data->Redistributables after changing the value in setup.exe, or you may get a different compilation error)

Charles.

0 Kudos