Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Map Drive / User Account Settings Problem


I have a problem with Installshield 2012 Spring.

We have several installers created by Installshield 2011 which we now upgraded to Installshield 2012 Spring.

In our installer, we have directory combo box which is displaying all local drives and mapped drives. But it doesn’t seem to be working in Installshield 2012 spring.

When I run an installer with Installshield 2011, it displays all mapped drives in list. When I run the same installer after upgrading solution to Installshield 2012 spring, it doesn’t display mapped drives.

So I looked around on internet and found that there are problems related to UAC (User access Control Setting in Windows 7).

As per one person’s advice,
If I turn off UAC, then it displays all mapped drives in installer which is created with 2012 spring. But if I turn on UAC ( Reboot PC after turn on UAC ), I cannot see mapped drives. Switching UAC off is not an option for our customers.

Is this a bug in InstallShield 2012 Spring?

I give you more details about my system.
Window 7
Installshield 2012 spring
SetUp.exe ( set Required execution level as Administrator. It is not working with any other settings such as Invoker, Highest Available )
Basic MSI Project
Labels (1)
0 Kudos
(3) Replies
Level 17

This is not a bug in InstallShield. This is related to UAC behavior on Windows Vista and later systems. It's described in the following blog post:
Mapped Network Drives with UAC on Windows Vista

Is it possible for you to use UNC paths instead of mapped drives?
0 Kudos
Level 2

Hi DebbieL,
Thanks for your reply.

I have tested your solutions on windows 7.

Steps :
1. Created new EnableLinkedConnections with DWORD value 1 in HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Policies/System.
2. Restart my PC.
3. Disconnected all mapped drives and re connect those again.
4. Restart my PC.
5. Run installer.

It doesn't display mapped drives.
Can you please tell me did I miss any thing?


0 Kudos
Level 17

To map the drive, you need to start an administrative command prompt and map the drives there using "net use M: \\server\path"
0 Kudos