cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Loic_Berthollet
Level 3

Lost INSTALLDIR

Hi,

While INSTALLDIR is well defined in the "Installation Designer" tab, "General Information / Product Properties", when I tries to use it in any "Destination" field, It takes a "0" value.
For example, in "Organisation / Setup Design", when I tries to setup the field "Destination", The "Browse for Folder" dialog box appears and shows "0" rather than [INSTALLDIR] and shows "0\Database" rather than "[INSTALLDIR]\Database." All other input from this dialog box seems ok.

Of course, the built setup does not work.

I tried to change the INSTALLDIR value, but it remains "0" in "Destinations" fields and in "Browse for Folder" dialog box.

Any idea ?

Thanks'.
Labels (1)
0 Kudos
3 Replies
Loic_Berthollet
Level 3

Resolved !

In the" Additional Tools / Direct Editor", there is a table nammed "Property". In this table 1 key have appeared: one "INSTALLDIR" with "0" as value.

I drop this data row, and tada, all is work now.
0 Kudos
Loic_Berthollet
Level 3

MSIYER wrote:
Try this:
Close the IDE and change the INSTALLDIR value in the .ism file.


Thanks' for your help, but I solved my problem as my other message tells.

But by the way, how can I change the INSTALLDIR value in the .ism file?
When a open it with Notepad, i see a binary file!
0 Kudos
MSIYER
Level 8

The INSTALLDIR value will change in the Property table of your msi. The Direct Editor exposes the table view to the dev. As you were not able to change it in the IDE, I thought IDE was misbehaving.

In any case, you can save your ism file as binary or xml. With xml you can edit ism with notepad. I had asked you to do that. A search would have eventually taken you to the Property table entry in the xml.
0 Kudos