cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

LaunchAppAndWait--app runs on Win2008, but not Win 2003?

I've got a Basic MSI project with an InstallScript deferred CA that launches an executable (really old velocis database server utility) with the name of a script file included in the install. If I run the setup on WindowsServer 2008, the CA runs properly. But if I run the setup on WinServer2003 (which the majority of our install base runs), the exe does not run the same way.

I tried 2 different ways of invoking the exe with LaunchAppAndWait

a) rsql.exe as program, file name to process as the command line argument.

In this case, I get the rsql execution window coming up with an error message that it could not open the command file I passed to it. I verified that the file is present. At the rsql prompt, I entered the exit command.

b) I wrote a RunScript.bat that is just rsql

In this case, I get an error from LaunchAppAndWait saying the runscript.bat could not be executed. Interrogating LAAW_PARAMETERS.nResultCode returns a code 3, but I have no clue as to what it means.

After the install is done, if I go to a command prompt and try either method, the program executes correctly.

Since this is working ok on Win2008, what can I look for to troubleshoot this?

I have verified that the executable and supporting files are the same on both systems.

As always, a quick response would be appreciated!
Labels (1)
0 Kudos
2 Replies
Highlighted
Pilgrim

Re: LaunchAppAndWait--app runs on Win2008, but not Win 2003?

return code 3 is ERROR_PATH_NOT_FOUND

everything looks like the path you specify does not exist on your Windows 2003. Try a MessageBox which shows you the exact Path to the exe and the commandline file.
0 Kudos
Highlighted
Pilgrim

Re: LaunchAppAndWait--app runs on Win2008, but not Win 2003?

I put some messaging in before the call to LaunchAppAndWait, the path is correct and does exist, but the program won't execute on Win2003, but does on Win2008.

What I eventually did was deploy the script file that I wanted to execute to FOLDER_PERSONAL, and ran it from there, and now the CA works correctly on both OS.

Thanks.
0 Kudos