cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
spothuri
Flexera beginner

Issues while migrating from InstallShield 2016 to 2019 R2

Hi,


We are now migrating projects from Installshiled 2016  premier comp to InstallShield 2019 R2PremierComp version.

 

We have one issue while creating IIS sites through the InstallShield. During IIS site creation, “System.web” section is being added to the server’s “applicationhost.config” file during the installation process. With this section, IIS sites are going to stopped state and we are unable to start them back because of this system.web section.

 

We have identified from where this “system.web” section coming, there is a new entry(Forms authentication) added in the authentication access section of IIS properties for Installshield 2019.

If I set forms authentication to “NO” then the tool is updating the applicationhost.config file as follows:

 

<location path="website">
        <system.web>
            <authentication mode="windows" />
        </system.web>
        <system.webServer>
            <handlers accessPolicy="Read, Script" />
            <directoryBrowse enabled="false" />
            <asp>
                <session timeout="00:20:00" />
                <limits scriptTimeout="00:01:30" />
            </asp>
            <security>
                <authentication>
                    <anonymousAuthentication enabled="true" />
                    <basicAuthentication enabled="false" />
                    <windowsAuthentication enabled="true" />
                </authentication>
            </security>
            <httpLogging dontLog="false" />
        </system.webServer>
    </location>

If forms authentication is YES then tool updating as :

 

 <location path="website">
        <system.web>
            <authentication mode="Forms" />
        </system.web>
        <system.webServer>
            <handlers accessPolicy="Read, Script" />
            <directoryBrowse enabled="false" />
            <asp>
                <session timeout="00:20:00" />
                <limits scriptTimeout="00:01:30" />
            </asp>
            <security>
                <authentication>
                    <anonymousAuthentication enabled="true" />
                    <basicAuthentication enabled="false" />
                    <windowsAuthentication enabled="true" />
                </authentication>
            </security>
            <httpLogging dontLog="false" />
        </system.webServer>
    </location>

 

My problem now is that the below section is being added to my IIS applicatiohost.config file, sites are not starting and application installation is failing.

 

          <system.web>
            <authentication mode="Forms" />
        </system.web> 

 

If I remove manually the above section, I'm able to start the IIS site without any issues.

 

In earlier versions, we never saw this issue.

 

We have compared our IIS website settings with 2016, everything seems the same except the new feature (Farms authentication) added in 2019  InstallShield.

 

 

spothuri_0-1574668416639.jpeg

 

Could you please provide your inputs on this issue?

 

Thanks.

Labels (1)
0 Kudos
3 Replies
spothuri
Flexera beginner

Re: Issues while migrating from InstallShield 2016 to 2019 R2

Hello Team,

Any update on this request?

Thanks.
0 Kudos
tanasico
Wanderer

Re: Issues while migrating from InstallShield 2016 to 2019 R2

Hello,

I have the same problem after upgrade projects to IS2019. Did you find a solution for this?

0 Kudos
spothuri
Flexera beginner

Re: Issues while migrating from InstallShield 2016 to 2019 R2

Hi,


We didn't get a reply back yet from Flexera support. We still have the same issue.

 

Thanks.

0 Kudos