Revenera Documentation site will be unavailable on July 2nd due to scheduled maintenance. For more information see the status dashboard.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
RomanK
Level 2

IsCmdBuild "-t" option

Hello,

I have a problem using -t option for IsCmdBuild. We have two versions of our product which requires different .Net frameworks (3.5 and 4.5).
We can build only one version at a time, changing the Tools->Options->.Net->.Net framework File Locations. The workaround for that, seems like, to use
IsCmdBuild with -t option specifying the path to required .Net version e.g. "C:\Windows\Microsoft.NET\Framework\v2.0.50727".

This works for our x86 version of installer, but does not work for x64 version, with the following error:

ISDEV : error -6209: Regasm.exe cannot be located on your system. This file is required to obtain .NET COM Interop information for Components. You can set the path to Regasm.exe using Tools | Options and/or specify the path with the -t commmand line build option. The file is part of the Microsoft .NET Framework redistributable. C:\Windows\Microsoft.NET\Framework\v2.0.5072764\RegAsm.exe

Please note, that it has added 64 in the wrong place, should have added it to Framework.

What can be done to workaround the problem?
Labels (1)
0 Kudos
2 Replies
groupjm
Level 3

Hello,

did you get an answer for this task? We do have the same problem here :(, so what can be done as a workaround :confused:?
0 Kudos
RomanK
Level 2

groupjm wrote:
Hello,

did you get an answer for this task? We do have the same problem here :(, so what can be done as a workaround :confused:?


I am not sure but I think they have fixed it. Are you using the latest version of your IS? For me, it looks like a very easy fix, but still has taken a lot of time to be fixed (if it has been fixed).

The workaround could ofcourse be to have two servers with IS installed on each, if you have licenses. Otherwise, you can try to use build agents (called something like that)

Best of luck 🙂
0 Kudos