cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
spiderlily
Occasional contributor

Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution

No matter the conditions or command line options, the Intel Visual Fortran 2019 for Update 4 Redistributable 64-bit prerequisite always fails.  https://software.intel.com/en-us/articles/redistributable-libraries-for-intel-c-and-fortran-2019-com...

This .msi installs fine when double-clicking, or when run from the command line with /quiet /qn /norestart.  Both the install as a prerequisite and the command line are done as administrator, so that's not the problem.

I am also installing a Visual C++ redistributable prerequisite, and that works fine.

0 Kudos
1 Solution

Accepted Solutions
Flexera Jenifer
Flexera

Re: Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution

Hi @spiderlily ,

 

Can you assist with me below details:

  • What is the OS-detail of the machine you are verifying?
  • Is it 32-bit or 64-bit?
  • I had attached working .prq file in the below attachment
  • Please change the .msi location of your machine specific and give it a try for UI installation.If that seems to be working then go for silent installation
  • I had validated this in both 32-bit & 64-bit which works with no issues

 

Thanks,

Jenifer

12 Replies
spiderlily
Occasional contributor

Re: Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution
0 Kudos
spiderlily
Occasional contributor

Re: Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution

I can tell that the registry comparison condition is not working, but the file version comparison (IntelCondition2.png) does work, because when I've already installed the redistributables outside of my InstallShield installer and then run my installer, I am not prompted that it is pending.

0 Kudos
spiderlily
Occasional contributor

Re: Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution
Although, still, when I don't already have it installed and attempt to install is as a prerequisite to my software, it fails.
0 Kudos
Flexera banna_k
Flexera

Re: Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution

Hi @spiderlily,

You can refer the MSXML 6.0 prerequisite, which uses file version comparison detection condition.

Apart from that it will be good if you specify the path using predefined variable instead of absolute path. 

And can you check manually what is the version before installation and what version got installed during the failure. Is the version installed satisfy the condition mentioned in the prerequisite. 

 

0 Kudos
Flexera Jenifer
Flexera

Re: Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution

Hi @spiderlily ,

 

Your registry condition needs to be given like this:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{23872E2A-4505-4C17-B971-4202705EE84F} rather than adding WOW6432Node in the registry key name itself.

The option :Check the following location on 64-bit system will take care whether to append WOW6432Node node or not.Here you can select 32-bit/64-bit based on your requirement. 

Please refer the attached snapshot.

 

Thanks,

Jenifer

0 Kudos
spiderlily
Occasional contributor

Re: Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution
Thank you both banna k and Jenifer for your replies. The file version condition I tried works, but I can certainly try using the predefined variable. I could also try the registry condition without the WOW6432Node part. I can tell the file version condition works because the Pending Installation doesn't appear if the redistributables have been installed manually before running my InstallShield installer. However, when they are not previously installed, the Intel Visual Fortran redistributable still fails when running as a prerequisite.

I've also considered whether the .msi has a problem being packaged in a single .exe, as I'm doing, but the separated files in Disk Images output also has the same problem.
0 Kudos
Flexera Jenifer
Flexera

Re: Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution
Hi,

Did you try with registry condition as referred in snapshot?

I had given a try and it worked. Can you confirm please?

Thanks,
Jenifer
0 Kudos
spiderlily
Occasional contributor

Re: Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution

Hi Jenifer,

Actually, no the condition doesn't work without the WOW6432Node specified in the registry path.  I took a screenshot of the registry showing the Intel Redistributables installed (previously), but the installer condition views it as not installed, and shows it Pending.

0 Kudos
spiderlily
Occasional contributor

Re: Intel Visual Fortran 2019 prerequisite fails no matter what

Jump to solution

Here's the failure of the condition.  It doesn't see that it is installed.

0 Kudos