Revenera Documentation site will be unavailable on July 2nd due to scheduled maintenance. For more information see the status dashboard.

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Installshield 2018 crash on build / MSI error 2919

Jump to solution

I am quite new and unexperienced to Installshield, I hope this issue has an easy solution.

I have a problem building a msi-package. I go through the release wizard and select to build an msi with 1 cabinet file per feature (the basic msi project only has 1 feature and 1 configuration and has network image selected). when Installshield is building the file it crashes with following error message:

Exception ACCESS_VIOLATION (0xc0000005)
at address 0x14f7552e trying to read address 0x00000170.

File : C:\Program Files (x86)\InstallShield\2018\System\isdev.exe
Version :
Exception : c0000005
Address : 14f7552e
Access Type : read
Access Address : 00000170

Registers : EAX=00000160 CS=0023 EIP=14f7552e EFLGS=00010206
: EBX=00000160 SS=002b ESP=0019d55c EBP=0019d568
: ECX=00000000 DS=002b ESI=0019d620 FS=0053
: EDX=00000000 ES=002b EDI=0019d61c GS=002b

Stack Trace : 150fd94a 150ffe42 150ffc0d 150febe7
: 150ad3ee 150acb5e 14f9bc52 14f9b226
: 14f9c7c7 0a526dd8 0a524667 0a4f5377
: 0a4f64eb 110158d1 1102c7f0 02901736
: 004263fc 0044b80c 71e24aa8 72d320fd
: 72d31a30 72c98bcb 72c98b6a 75aa635b
: 75a9729c 75a967ef 71eb4681 75aa635b
: 75a9729c 75a963db 75a961b0 72cba003

the last entry in the building log is Media table successfully built

This happens not only with that one project but with another one which are related to an other. Both share the fact that they have to be installed into the same subfolder of D:\. So I have defined the INSTALLDIR to be D:\Folder by typing it in at General Information. Please note that both packages belong to the same software but needs to be in 2 parts for maintainance reasons.

When I select to compress the files inside the msi, the msi-file is built successfully, but installation cancels with error 2919 (No cabinet specified for compressed file). This happens with both projects. All files to be built into the resulting msi-file are added with dynamic links and self registering enabled.
I also tried uncompressed, which built successfully, but then during the installation the msi runs every exe-file in the package (why does it do that?) and throws a ton of error messages.

Either compressed inside or with cabinet file works for me, but this error needs to be fixed one way or another. Internet research for both error 2919 and the crash wasn't helpful. Please advise.

Labels (1)
0 Kudos
1 Solution
Revenera Moderator Revenera Moderator
Revenera Moderator

I have seen the 2919 error occur due to the "Previous Package" setting under Releases > Build tab.

If you have a value in this setting, try removing it and testing the build/install again.

View solution in original post

0 Kudos
6 Replies
Level 13

Something to try:

Click on the 'Project Assistant' tab near the top of the IDE.

Click on 'Installation Interview' near the bottom of the screen.

Verify that the 'No' radio button is selected for the "Do you want to give users the option to launch your application when the installation completes?" (bottom item)

0 Kudos

Yes, it is disabled.  I haven't changed this particular setting to begin with

0 Kudos

Update: I have rebuilt the smaller easier to build msi (only files/folders to put into installdir D:\Folder) from scratch. I deleted everything besides the sources and started over and now it worked without issues. The msi with files compressed inside does not run into error 2919 and installs properly. I did nothing different to the previous tries (at least I believe so).

The other package still doesn't work. I rebuilt that package from scratch too. Tried with changing the INSTALLDIR, deleted a required service to be installed, tried with not using dynamic links on adding files/folders, tried both using and not using self registration with dynamic links on adding files/folders. In desperation I even tried with extracting the cab out of the msi and putting next to it.  All to no avail Smiley Frustrated

Any ideas to sort that out? Any help is highly appreciated!

0 Kudos
Revenera Moderator Revenera Moderator
Revenera Moderator

I have seen the 2919 error occur due to the "Previous Package" setting under Releases > Build tab.

If you have a value in this setting, try removing it and testing the build/install again.

0 Kudos

Dead on target! I did not expect this to be the reason of the issue! Thank you very much! Smiley Very Happy

0 Kudos

We have the same error, it crash when we launch the build, we use InstallShield 2018 express and there is no "build tab" under Releases

Here is what I tried :

Installation Designer > Prepare for release > Releases > then there is on the right Builds /Express->  Custom , single image etc

then if I select any of those links, then Build (from the menu), it crash

same issue using the Project assitant, it crash at the last step, when launching the build

any help will be highly highly appreciated.

Thank you

0 Kudos