Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

InstalllShield 2018 R2 installer won't register Visual Studio 2019 extension

When I install InstallShield 2018 R2 , I don't get any extensions installed for Visual Studio 2019. This means that I can't edit .isproj files, Visual Studio says they are unsupported. How can I register InstallShield 2018 RS so that I can edit or even load my isproj files in Visual Studio 2019?

Labels (1)
0 Kudos
6 Replies
Flexera Alumni

Hi @shackett ,


What was the order of installation of those two software?

  • Expectation here is installation of visual studio first then installshield
  • If it is of reverse,try executing TSConfig.exe /registerVSIP from  cmd by navigating to [PROGRAMFILESX86]Installshield\[2018]\System folder




0 Kudos

Hello. I have IS 2020 working with VS 2013 integration and am upgrading to VS 2019. How can I enable integration with VS 2019? TSCONFIG did not work. Also tried installation repair. Will try uninstall/reinstall next, but there should be a better way.

0 Kudos

Hi @jerrym,


  If you have installed InstallShield 2020 on a machine where you have installed VisualStudio 2019 professional or higher, then you can run the below command from an administrator command window :

1- C:\Program Files(x86)\InstallShield\2020\System\TSConfig /unregisterVSIP 

2- C:\Program Files(x86)\InstallShield\2020\System\TSConfig /registerVSIP


The above command reintegrate InstallShield with visual studio again.


0 Kudos

Jenifer - I'm resuming this effort at our company for shackett.  I tried running TSConfig.exe /registerVSIP from the command line, per your suggestion, but it didn't help.  Do you have another suggestion?  As a reminder, we are trying to open a solution that contains an Install Shield (.isproj) project in Visual Studio 2019, after installing Visual Studio 2018 R2.

0 Kudos

Hi @jkcraig ,


Hope you have executed the "TSConfig.exe /registerVSIP" in an administrator command prompt from InstallShield 2018 R2 system folder.

If InstallShield 2018 R2 failed to integrate with VS2019 after executing above command, then please reach out to Revenera support to analyze this further.

0 Kudos
Level 2

To share my experience:  The above commands did not work with Visual Studio 2019 (16.11.9).  Yes I ran them as an administrator.  I tried every combination of command, rebooting, installing software, nothing worked.

On a whim I decided to install VS2017.  After running those commands, VS2017 recognized InstallShield! 

After that I went back to VS2019 and behold it now finally recognizes InstallShield. 

Hope this helps someone.

0 Kudos