Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 4

Installer thinks directory exists but it does not

I have been banging my head on the wall trying to figure this out. Our latest installer, Installshield 2016, is looking for some directories that we used to create with our older software to do backups of files and what not. This all works great on an older system. Running this on a brand new machine its not working. No matter how I check for the directory Installshield is saying it exists but it does not. I have tried using ExisstsDir, I have tried Is(PATH_EXISTS and it also returns that the directory exists. Looking at the file system the directory does not, writing a C# program, .NET returns false the directory does not exist so why in the hell does Installshield say its there.
Labels (1)
0 Kudos
(3) Replies
Level 8

InstallScript is executed as 32-Bit process and a .NET program on a 64-Bit OS as 64-Bit process. So this could be different. For what folder do you check ?


0 Kudos
Level 4

Our older software was very bad and installed directly onto C:\ so it is not an issue of 32/64.
0 Kudos
Level 9

I've never had the built-in InstallScript stuff fail to work. But, these days rather than use InstallScript much at all I just use C# and call it from my installer as a Custom Action - either on a button click or in one or the other sequences or both (UI or Execute).

Much easier to debug, too, I find.

0 Kudos