cancel
Showing results for 
Search instead for 
Did you mean: 
pmeklin
Pilgrim

InstallShield installation problem

Hi, we have a problem with installing a new InstallShield version (2016). My associate tried to install new version of InstallShield from package InstallShield2016PremierComp.exe, but it won’t install. When doubleclicking the file it tries to extract it or something, but after couple of seconds it just stops and nothing happens. I installed from same file successfully so it is not corrupted.

What can be done?

Kind regards
Pete
Labels (1)
0 Kudos
20 Replies
Highlighted
joshstechnij
Pilgrim

Re: InstallShield installation problem

It sounds like an error may be occurring during initialization of the installer. On the machine that has this issue, can you run the IS 2016 installer with logging enabled?
InstallShield2016PremierComp.exe /debuglog


This should create a log file in the same folder as the EXE when it is run with this command line. Please attach the verbose log to this thread.
0 Kudos
pmeklin
Pilgrim

Re: InstallShield installation problem

Thanks for your response. Here is the log file.

Regards,
Pete
0 Kudos
joshstechnij
Pilgrim

Re: InstallShield installation problem

The following line indicates an issue:
[code]9-21-2016[09:01:43]: UI resource exception: 80070057[/code]

We have seen this issue a few times recently but unfortunately we have not been able to track down what specifically is causing the issue. We do know that the error is being returned from the Win32 API required to succeed for the setup UI to function, but the error code (invalid parameter) does not make any sense as we have been able to verify in other cases that all the parameters are valid. This issue is also difficult to diagnose due to the machine specific nature that we have not been able to reproduce.

If possible, we have some troubleshooting test utilities we would like to try on the machine encountering this error. I will send you a private message containing further details regarding the tests we would like to try.
0 Kudos
pmeklin
Pilgrim

Re: InstallShield installation problem

Ok. That's fine with me. I'm in the office in the next week.

Regards
Pete
0 Kudos
David_Lehman
Pilgrim

Ditto for me

Any movement on this issue? I'm having trouble with the same installer running on a Win7 64 bit machine. Installer silently fails and log shows UI resource exception: 80070057...
0 Kudos
joshstechnij
Pilgrim

Re: InstallShield installation problem

David,

As mentioned before we are seeing multiple reports of this issue but we are unable to reproduce it in house. We have been able to obtain a fair amount of data about this issue from machines that are encountering it. We currently believe that a change we made in IS 2016 and a hotfix for IS 2015 SP1 to provide greater security when loading arbitrary third party DLLs is partly the cause of this behavior. It appears that the SetDefaultDllDirectories API used to accomplish this is causing certain functionality in other Win32 APIs to fail.

At this point we are still trying to track down a specific cause for this marshaling error (which results in the suite error "UI resource exception" in the suite debug log). I've attached a test EXE we have been able to put together that reproduces this behavior outside of an installer process. Can you do the following with the test EXE:
[LIST=1]
  • Extract the EXE from the zip file.
  • Open a command prompt window and run the EXE:
    MarshalTest.exe

  • After the EXE writes 'Starting CoMarshalInterface test...' to the console, watch for any LoadLibrary errors with the error 0x00000057.
  • If such an error occurs, the EXE will wait for you to create a process dump in Task Manager. Open Task Manager, find MarshalTest.exe, right-click it and select 'Create Dump File...'.
  • Press a key to continue the test after creating a dump file.
  • Attach the dump file (zipped) and any output from the test EXE to this thread. (Note that it may not be possible to attach the dump due to its size; if possible, upload to a file sharing service that we would be able to access.)
  • 0 Kudos
    pmeklin
    Pilgrim

    Re: InstallShield installation problem

    Hi Josh,
    sorry about the delay with my response. Here are the log files created with tools submitted in your private mail.

    Regards
    Pete
    0 Kudos
    joshstechnij
    Pilgrim

    Re: InstallShield installation problem

    Pete,

    Thanks for getting this information to us. It looks like the machine this test was run on is encountering the same exact behavior as other machines we are seeing. For some reason a call into MSI occurs on the machines with this issue when we make a call into CoMarshalInterface.

    Would you be able to run the test posted above with the attached MarshalTest.zip? We believe we know the code change we made that is causing parts of Windows to behave unexpectedly, but we're looking for one last bit of data before making a decision on how to fix the issue. If you are able to run the test, the MarshalTest.exe process dump is likely going to be too large to attach here. If you can, try putting the file on a file sharing service (OneDrive, Drop Box, etc.) that we would be able to access.

    Thank you for your patience as we try to get a fix available for this issue.
    0 Kudos
    pmeklin
    Pilgrim

    Re: InstallShield installation problem

    Hi Josh,

    we tried that, but we couldn't get a dump because the exe ended straight away after error.



    Regards
    Pete
    0 Kudos