cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

InstallShield 2018 R2 MSIX Build Error

Hello,

I am trying to build an MSIX package using InstallShield 2018 R2. When I create a basic MSI project and try to enable MSIX package building I get the following error

Schema validation error in AppxManifest.xml(0): Element '{http://schemas.microsoft.com/appx/manifest/foundation/windows10}Applications' cannot be empty according to the DTD/Schema.

I have the Windows Preview SDK installed and I am building on a Windows 10 machine, but my OS Build number is 16299.1625.

My question is, is my machine not configured properly? Or am I not able to build because of corporate controls on my machine (such as my OS version number, and the fact that the Windows Store is disabled on my machine). Unless there is a bug with the software.

0 Kudos
1 Reply
Highlighted
Flexera
Flexera

Re: InstallShield 2018 R2 MSIX Build Error

@tk2891  : It looks like the application entry in the package is not configured, you can configure the application entry in the short cut view by creating a shortcut in the desktop. Adding an application entry to your package may resolve the schema validation error.

 

More info on how to create shortcut: https://helpnet.flexerasoftware.com/installshield24helplib/helplibrary/TutorialShortcut.htm

0 Kudos