cancel
Showing results for 
Search instead for 
Did you mean: 
dave_krekel
Flexera beginner

InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

I am having trouble with the installation order with a single prerequisite for the install.

For some reason it works on another  build environment but it does not work on ours even though the installation routines are the same. InstallShield is not waiting for the first install to complete before starting the second.

I tried to upgrade to SP2 to see if it would resolve the problem but I am getting the following error. 

It is trying to activate the product again. I get the following error when I hit the activation button.

Error 51311 - One of more response actions failed.

Any Ideas why it is trying to activate a product that is already activated?

Thanks

0 Kudos
15 Replies
Flexera Jenifer
Flexera

Re: InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

Hi @dave_krekel ,

Answering to your queries:

  • For some reason it works on another  build environment but it does not work on ours even though the installation routines are the same. InstallShield is not waiting for the first install to complete before starting the second.-Can you elaborate a bit?
    • What is first installer,basic MSI/installscript MSI/Any pre-requisite?
    • What is second installer?
  • Error 51311 - One of more response actions failed.Can you try below:
    • 1. Close InstallShield
      2. Locate TSConfig.exe on the machine (the default location is: C:\Program Files (x86)\InstallShield\2016\System)
      3. From a command prompt, run the following command: TSConfig.exe /return
      4. From a command prompt, run the following command: TSConfig.exe /activate
      5. Enter your serial number
    • If this doesn't work please contact InstallShield support,they will be proper candidate to help you with activation issue asap via

Thanks,

Jenifer

0 Kudos
Highlighted
dave_krekel
Flexera beginner

Re: InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

Thanks Jenifer,

I tried the steps listed below to return and activate the InstallShield but I still get the 51311 error when I attempt to upgrade to 2016 SP2.

On the installation order issue. On the "Application Data" folder, Redistributables we have the following checked (see list below). The only change I did was to as to add 4.7.2 frame work to the folder structure, uncheck 4.6.2 framework and checked the 4.7.2 framework.

The expected result is when installing or application on a clean machine the following would occur:

1) Install Shield would install the 4.7.2 framework (select the restart later option).

2) Once the 4.7.2 frame work install completed, InstallShield would start and complete our application install.

What we are experiencing is our application install is starting before the prompting/install for the 4.7.2 framework has completed.

We were one company but split into two companies a couple of years ago. We have a separate build environments and licenses but we essential have the very similar instances of InstallShield. The other company is running 2016 SP2 and we are running 2016 SP1. One of the reasons I was trying to upgrade to 2016 SP2. I wanted to see if this would correct the install problem.

Hope this helps I have tried to compare the two instances as much a possible.

Is there a configuration setting that I might have disabled when un-checking 4.6.2 that did not reset when I checked 4.7.2?

Is there something in Install Shield beyond the following members that would cause this issue: AIsGlobals.rul
AIsRoutines.h, AIsRoutines.rul, Setup.Rul. These were source members I manually synced from the other companies build machine in my attempt to resolve the issue.
 

List modules checked.

Visual C++ 10.0 DebugCRT (x86) [Version=10.0, Type=Merged Module, Installed Locally]

Visual C++ 10.0 CRT (x86) [Version=10.0, Type=Merged Module, Installed Locally]

c:\Program Files (x86)\InstallShield\2016\Objects\MicrosoftSqlServerSpatialX86.msm [Version=1.0.0.0.0, Type=Merged Module, Installed Locally]

MapSuiteProj4MergeModule [Version=1.0.0.0.0, Type=Merged Module, Installed Locally]

MapSuiteMrStd [Version=8.0.0.0.0, Type=Merged Module, Installed Locally]

MapSuiteGeoTiffMergeModule [Version=1.0.0.0.0, Type=Merged Module, Installed Locally]

Map [Version=1.0.0.0.0, Type=Merged Module, Installed Locally]

MapSuiteEcw [Version=8.0.0.0.0, Type=Merged Module, Installed Locally]

MapSuiteCadMergeModel [Version=1.0.0.0.0, Type=Merged Module, Installed Locally]

Microsoft Data Access Components 2.8 (English) [Version=1.0.0.0.0, Type=Merged Module, Installed Locally]

Microsoft .NET Framework 4.7.2 Full [Version=1.0, Type=InstallShield Prerequisite, Installed Locally]

 

0 Kudos
Flexera Jenifer
Flexera

Re: InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

Hi @dave_krekel ,

 

Thanks for the detailed information.

About activation issue i hope you had already contacted Flexera support.In the meantime  go to the below document and refer the topic 'Activating Through a Web Page'

https://helpnet.flexerasoftware.com/installshield25helplib/pdf/InstallShield2019_ActivationUserGuide...

But one question:

  • Are you getting the same error on installing direct IS2016 SP2 activation too?

Below link can help you understand more about pre-requisite's runtime behavior:

https://helpnet.flexerasoftware.com/installshield19helplib/helplibrary/IHelpSetPrereqRun.htm

You can enable pre-requisite installation progress using behavior tab:

https://helpnet.flexerasoftware.com/installshield25helplib/helplibrary/UIRefPrereqEditor_Behavior.ht...

by which you will get to know status messages.

 

Thanks,

Jenifer

 

 

Thanks,

Jenifer

0 Kudos
dave_krekel
Flexera beginner

Re: InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

I was successfully able to work with support to reset my license so I could update my InstallShield 2016 software to SP2. 

I ran a build on Friday after upgrading to SP2 and we still have the problem.

The challenging part of the issue our company has two similar build environments (used to be one BU but split into 2 BU's about 3 years ago). So for the most part our two build machines are exactly the same (except for our development code base.) The other BU upgrade their dotnet framework requirement 4.6.2 to 4.7.2 last year and their install process works fine. 4.7.2 installs first and then our product installs. 

Our customers will usually select the restart later option on both the 4.7.2 install and our product install since they use the down time to perform other maintenance functions.

Attached is a document with the prerequisite setup screens. All the entries between the two build environments are exactly the same.

Is there some other area within install shield I need to check for differences between the to environments that would cause the error?

Also I did experience some challenges in adding 4.7.2 as a prerequisite to our build environment.  But both machines are using the same prerequisite file.

Any Ideas? We are planning to release at the end of Sept/2019 but it will not happen if I cannot find a resolution to this issue.

Thanks.

Dave

 

0 Kudos
dave_krekel
Flexera beginner

Re: InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

Here is a word Doc that contains the prerequisite setup.

0 Kudos
dave_krekel
Flexera beginner

Re: InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

I am doing an experiment. I removed the 4.7.2 frameworks as a prerequisite. Just to see if our application will install properly.

Do you have any ideas on my situation? I have been essentially been down for about a week now.

Thanks

0 Kudos
Flexera Jenifer
Flexera

Re: InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

Hi @dave_krekel ,

 

Can you please help us with few details:

  • "Our customers will usually select the restart later option on both the 4.7.2 install and our product install since they use the down time to perform other maintenance functions."
  • Question-In the working machine too  with selecting restart later option installation order works fine?
  • In both the build environments,operating systems are same?if not what are OS details of both?
  • Is there some other area within install shield I need to check for differences between the to environments that would cause the error?-
    • Answer:I dont think so,there is any.But you can take both the build environments installShield project files(.ism) and see the difference using MsiDiff.exe too which you will be able to find via shortcut or in System folder of InstallShield(<IS-INSTALLDIR>\<2016>\System.That can give you some clue
  • Any specific reason behind /showrmui /passive /promptrestart commandline?
  • "Also I did experience some challenges in adding 4.7.2 as a prerequisite to our build environment.  But both machines are using the same prerequisite file."
    • Question-what are the challenges you face?
  • I am attaching .Net 4.7.2 full.prq which is available with current InstallShield ,please give a try.

Let me know if that helps,

Thanks,

Jenifer

0 Kudos
dave_krekel
Flexera beginner

Re: InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

Morning Jenifer,

Here are the answers to your questions.

Your Question-In the working machine too with selecting restart later option installation order works fine?

Answer-The other product install seams to work fine.

Your Question-what are the challenges you face?

Answer-It took a while to where 4.7.2 framework was actually a select-able item on the prerequisite screen. Is that causing a problem?

 

I unchecked 4.7.2 as a prerequisite, compiled install shield, rebuilt our install and applied it to our test server. I still got the prompt for the 4.7.2 install. 

My Question-Can I manually delete 4.7 directory? 

C:\Program Files (x86)\InstallShield\2016\SetupPrerequisites\Microsoft.net\4.7\Full  

I wanted to see if rebuilt the install without 4.7 to see if out product would install correctly.

Here is the file that is currently in 4.7/Full directory: NDP472-KB4054530-x86-x64-AllOS-ENU.exe

I manually had to add the 4.7 directory in order to be able to pick 4.7.2 as a prerequisite.

My Question-Is this the normal way to add a prerequisite to install shield?

Thanks 

Dave

0 Kudos
Flexera Jenifer
Flexera

Re: InstallShield 2016 Professional Edition version 23 SP1, Error upgrading to SP2

Hi @dave_krekel ,

 

Answering to your queries:

Question-It took a while to where 4.7.2 framework was actually a select-able item on the prerequisite screen. Is that causing a problem?

  • I dont think that might be the cause,general way of getting pre-requisite files would be select the pre-requisite item which will ask for whether to download files (or opt for Download selected item).. which will automatically download files given downloadable link inside pre-requisite.i would suggest you to try with previously attached .prq file which has all those in place by adding which ever additional stuff you need.

I unchecked 4.7.2 as a prerequisite, compiled install shield, rebuilt our install and applied it to our test server. I still got the prompt for the 4.7.2 install. 

My Question-Can I manually delete 4.7 directory? 

  • If you uncheck it shouldn't be asked for installation prompt,you can quickly have a look at ISSetupPrerequisites table(via direct-editor view) if the entry is been removed after deleting the DISK1 directory as a clean build
  • Yes you can delete directory if you dont want installation to happen

 

  • Question: Did you try seeing the differences between both of build environment's project files(.ism) using MsiDiff.exe tool?Did that help?
  • Question:Both of build machines are of same operating systems if yes/no what is that?

 

Thanks,

Jenifer

0 Kudos