palanisamy
Flexera beginner

InstallScriptMSI project Text File Change Issue

My project type is InstallscriptMSI project.. I use "TextFileChange" IDE option to change the content of "sample.config" file.

During the new installation files are copied to installation path successfully and text file changes are done successfully.

The issue comes after the config file made changes, installation completed with out displaying the finish screen, application not displayed in Add/Remove program list.

I here attached the log file of sample installation.
Labels (1)
0 Kudos
11 Replies
KrisVanherck
Pilgrim

this doesn't look like a full verbose log file to me

you want to call your installer like this:
setup.exe /v"/l*v C:\MyLog.log"
0 Kudos
ch_eng
Flexera beginner

If you're trying to modify an app.config file, have you tried XML file changes instead?
0 Kudos
palanisamy
Flexera beginner

Hi KrisVanherck,
I Here attached the full msi log according ur guidance.
0 Kudos
palanisamy
Flexera beginner

Hi Accresso Team

This issue is an bug in installshield2010.
0 Kudos
hidenori
Pilgrim

If you create a new InstallScript MSI project from scratch, and only add a text replacement to modify the "sample.config" file, is the problem reproducible?
0 Kudos
palanisamy
Flexera beginner

Hi Hidenori,

I created New Installscript msi Project, yes this problem is reproduceable..
I try two or more times this problem araise repeatly...

Following Scenario to reproduce in Installscript MSI project, I did't try this option in BasicMSI project

1.) In IDE open TextFile changes option
2.)Add Replacement set in TextFile changes
3.) Target folder = [INSTALLDIR] Include Files = Sample.config, it will run only on install
4.) Add replacement from Sample.config replacement set.
5.) In "find what" add this string
6.) In "Replace With" add this string

please Try above scenario and confirm whether it is my mistake or installshield bug.
0 Kudos
hidenori
Pilgrim

It is not reproducible on my side. I may be missing something. Would it be possible for you to post your sample.config file? I also need more detailed reproduction steps on how you run the setup.

Thank you.
0 Kudos
palanisamy
Flexera beginner

Hi Hidenori,

Content in the Sample.config file as shown below
-----------------------------------------------------








---------------------------------------------------------------------

These are the following steps to reproduce the problem

1.) Add "Sample.Config" file as componet and set installlocation is "[INSTALLDIR]"
2.)Add Replacement set in TextFile changes
3.) Target folder = [INSTALLDIR] Include Files = Sample.config, it will run only on install
4.) Add replacement from Sample.config replacement set.

5.) In "find what" add this string

6.) In "Replace With" add this string
0 Kudos
hidenori
Pilgrim

Thank you for the information. Now I am able to reproduce the problem. I filed the work order #IOA-000052853 so that it will be fixed in a future release. Also, we are currently working on the hotfix for IS 2010. I will post more information as soon as it is available.

Thank you again for reporting this, and for your cooperation.
0 Kudos
hidenori
Pilgrim

I attached the #IOA-000052853 hotfix for IS 2010 SP1 to this post. In order to apply the fix, you need to copy the ISSetup.dll to the C:\Program Files\InstallShield\2010\Redist\Language Independent\i386 folder, and then rebuild your setup. Note that it is an unofficial fix as it is not fully tested by our QA team. So I would strongly recommend that you make a backup of the original file before applying it. Also, this issue only applies to InstallScript MSI projects, but Basic MSI projects.

Regards.
0 Kudos
palanisamy
Flexera beginner

Hi Hidenori san,

Thanks for ur kind support..
0 Kudos