cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

Install dialogs display rectangular box, See attached images

Hello there, I have been developing a basic MSI installer recently. I have two machines, one is my develop machine(Windows 7), the other is my build server(Windows server 2003). The exe pacakge and English MSI package built by both machines are ok. However, if I choose to build a MSI package with default language set to Chinese, my develop machine can produce correct MSI package, while the MSI package build by my build sever have dispaly problems, it can't display Chinese charactor correctly, instead, it only displays rectangular boxs, see attached images. I thought my build serve may lack of Chinese font, so I installed "East Asian Languages" in the control panesl's "Regional and language setions", but the problem still exists, could anybody give me a hint what I might missed, thanks in advance 🙂
Labels (1)
0 Kudos
7 Replies
Highlighted
Pilgrim

Re: Install dialogs display rectangular box, See attached images

If the build installs have the same behavior on both machines (e.g. the win7-build show ok on both and the win2k3-build shows block on both) then i would suggest that this is a build time issue and not a runtime problem. You did rebuild after the east-asian language install 😉 Are both installshield installations same version/hotfix and so on...
0 Kudos
Highlighted
Pilgrim

Re: Install dialogs display rectangular box, See attached images

On my build server, both MSI packages built by my dev machine or build server itself can't display Chinese charactors correctly. However, there are some differences. The one from my dev machine display unreadable charactors, see attached images. The one from my build server itself just show blocks, see the images I attached in the initial post. On my dev machine(windows 7), the MSI build from my dev machine itself can display Chinese charactor correctly, but the build from my build server just show blocks. I have installed "East Asian Languages" on my build server(windows server 2003). The InstallShield version for my dev machine is IS2010 sp1 with hotfix 52410, while my build server is IS2010 standalone build engine without IDE. I think it is very possible my build server still lack of fonts...
0 Kudos
Highlighted
Pilgrim

Re: Install dialogs display rectangular box, See attached images

I have done two things and it finally works.

1. I installed MICROSOFT WINDOWS MULTILINGUAL USER INTERFACE (MUI) PACK on my build server. After this step, charactor still have display problems.
2. I made the following change in control panel-> Regional and language settings->Advanced->select a language to match the language version of the non unicode programs you want to use
change from English to Chinese(PRC)

After that, the Chinese MSI package can display charactor correctly, don't know whether the first step matters...
0 Kudos
Highlighted
Pilgrim

Re: Install dialogs display rectangular box, See attached images

Did you try building a UTF-8 package?
0 Kudos
Highlighted
Pilgrim

Re: Install dialogs display rectangular box, See attached images

Thanks, very good suggestion, in the release panel-> Build UTF-8 Database, I choose yes, am I doing the right thing? Now it can display Chinese characters correctly, does this setting have other side effects?
0 Kudos
Highlighted
Flexera
Flexera

Re: Install dialogs display rectangular box, See attached images

Yes, please see the in-line help for that setting. Due to limitations in Windows Installer, it can result in a tiny font used in basic UI dialogs (such as those used when uninstalling from the control panel).
0 Kudos
Highlighted
Pilgrim

Re: Install dialogs display rectangular box, See attached images

Got it, thanks very much. 🙂
0 Kudos