cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pradana
Level 6

IIS7 Issue: Application or Virtual Directory?

Hi

I'm creating a Web Setup project which creates a virtual direrctory in IIS. in IIS 5.1 and IIS 6 it works fine,. When I tried to install to IIS7 (Win 2008), it creates an application with a virtual directory inside that application with exactly same name & contents.

How to prevent this happen? Thanks.

Here I attach the screenshots:
Left: Content of web application
Right: Content of virtual directory

See that both web app & virtual dir have exactly same name & contents, and they both refer to the same physical directory.
Labels (1)
0 Kudos
4 Replies
joshstechnij
Level 10 Flexeran
Level 10 Flexeran

This will be resolved in the next release of InstallShield. With IS 2009, you may try using the legacy IIS support by adding the property IISPREFERLEGACYOBJECTS to your project and setting its value to 1. Note that this will then require the IIS metabase compatibility option to be installed on IIS 7 machines.
0 Kudos
pradana
Level 6

joshstechnij wrote:
This will be resolved in the next release of InstallShield. With IS 2009, you may try using the legacy IIS support by adding the property IISPREFERLEGACYOBJECTS to your project and setting its value to 1. Note that this will then require the IIS metabase compatibility option to be installed on IIS 7 machines.


Can I have the steps how can I achieve this? Thanks. 😉
0 Kudos
joshstechnij
Level 10 Flexeran
Level 10 Flexeran

I apologize for any misunderstanding, but I'm not sure what you are asking. Is there something specific you were trying to accomplish?
0 Kudos
Not applicable

Josh,

I am also facing the same problem. I have Installshield 2009 and the web application deploys in the same manner as mentioned in the screen shot. Do you have any updates on this issue?

Regards,
Naveen
0 Kudos