naveen9396
Occasional contributor

I am getting install welcome dialog when I am trying to re-run the application

Jump to solution

Hi,

I build an Installer with the help of Installshield. I ran the installer when the product was not installed in my system. Later, I tried to re-run the Installer again. I expected Maintenance welcome dialog to popup but I got Install Welcome dialog. 

What can I do to get the Maintenance Welcome dialog during the time of re-running the application

 

Thanks,

Naveen G

Labels (1)
0 Kudos
2 Solutions
naveen9396
Occasional contributor
Hi Vijay,
Thanks for the Reply.
I realized my mistake. I didn't set the Condition for InstallWelcome Dialog Under Custom Action and Sequence -> "Sequence".

Condition as "Not Installed"

View solution in original post

0 Kudos
naveen9396
Occasional contributor

Please find the attachment for my previous post

View solution in original post

0 Kudos
3 Replies
varul
Revenera
Revenera

What is your project type?

Is your project installed successfully in the first time?  Please check in control panel for entry after first time installation?

Are you trying to run  second time from installshield IDE RUN button?

If you are trying to run from installshield IDE, then its expected, because by default installshield RUN button will uninstall the setup and then it will run the setup again,(its for testing purpose to make sure the setup is running successfully).

If you want to go to maintenance dialog go to setup.exe path in disk1 folder and run the setup.exe, you will see the maintenance dialog (Refer attachment)

Regards,

Vijay.A

0 Kudos
naveen9396
Occasional contributor
Hi Vijay,
Thanks for the Reply.
I realized my mistake. I didn't set the Condition for InstallWelcome Dialog Under Custom Action and Sequence -> "Sequence".

Condition as "Not Installed"

View solution in original post

0 Kudos
naveen9396
Occasional contributor

Please find the attachment for my previous post

View solution in original post

0 Kudos