cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
parajaganesh
Level 3

Giving permission for "Everyone" in non-english OSes

Hi,

I have a Installlscript MSI setup. I am using CACLS to give "Everyone" full access to some web sub-folders after install was finalized. I use this in my custom action:

cacls.exe "[INSTALLDIR]Myprogram\MySub-Folder" /e /g Everyone:F

It works on English operating systems but it fails on non-english ones, I think because they cannot realize the word "Eveyone". Has anyone had this problem before? what is the work around?

Thanks in advance.

- Ganesh Kumar
Labels (1)
0 Kudos
5 Replies
thepeter
Level 7

Use 'SID: S-1-1-0' instead of 'Everyone'
http://support.microsoft.com/default.aspx/kb/243330

Peter
0 Kudos
parajaganesh
Level 3

Hi Peter,

I have tried it in command line in two machines. It shows the following error:

C:\>cacls "C:\Documents and Settings\All Users\Application Data\MyDir" /E /G S-1-5-32-544:F

First Machine:

No mapping between account names and security IDs was done.

Second Machine:

The trust relationship between the primary domain and the trusted domain failed.

Pls suggest an alternate.

Regards,
Ganesh Kumar
0 Kudos
thepeter
Level 7

What OSs are your machines running?
0 Kudos
parajaganesh
Level 3

XP and Vista
0 Kudos
manomatt
Level 8

i am having the same issue. i tested it in Vista machine but in xp its working file.

Is there any work around for this?? Please post it
0 Kudos