Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

GPO Deployment Fail, Installation Abort before OnBegin() function called.


I recently ran into an issue installing our software installer by silent installation mode using group policy deployment.

Our InstallShield version is InstallShield 2013 – Professinal Edition (Version 20), and the project type is InstallScript Project.

The following steps had been taken before executed silent installation using group policy deployment:

1. Run the installer with additional parameters to record the install and create a response file. Example: "setup.exe /r /f1c:\temp\setup.iss"
2. Prepare GPO Deployment. The following command is executed in order to call the software installer :
"\\DCSERVER\GPO\setup.exe" /s /v"/PARAMPATH=\\DCSERVER\GPO\" /f1"\\DCSERVER\GPO\setup.iss" /f2”\\DCSERVER\GPO\silent_install.log"

The installation worked perfectly from manually running the command in step2 from an administrative command prompt.
When I tried deploying this software from GPO, using the same command line and the same response file, the installation failed without throwing silent installation log.
We also found that the installation had not even run into the first line of my sourcecode which is in OnBegin() function in Setup.rul script file.

As checked from the window event viewer log, we found the following error from the log:

Faulting application name: setup.exe, version:, time stamp: 0x51a6cc99
Faulting module name: ISSetup.dll, version:, time stamp: 0x51a6cc32
Exception code: 0xc0000005
Fault offset: 0x0001ab47
Faulting process id: 0x170c
Faulting application start time: 0x01cfbdd49884cd72
Faulting application path: \\DCSERVER\GPO\setup.exe
Faulting module path: C:\windows\TEMP\{20539092-BFF2-421F-BABE-D1AF6B1B8566}\Disk1\ISSetup.dll
Report Id: d6d2dc44-29c7-11e4-b576-005056c00008

When the software executes, the first thing it does is extract files into a temporary location.

If I run it manually, those files are placed in c:\users\<- username ->\appdata\local\temp\ with 2 temporary folder with GUID name format.
One contains ISSetup.dll and the other contains all installation support files.

If I run from GPO as System Account, those files are placed in c:\Windows\temp\ with only 1 temporary folder which contains ISSetup.dll.
The folder which contains all support files was not generated, and the installation was failed.

Would you please suggest how we can troubleshoot and resolve the problem as the software installer has been terminated before any log files are generated ?

Labels (1)
0 Kudos
(1) Reply
Level 2

Update the installshield program to Service Pack 1 will solve the issue. 🙂
0 Kudos