Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 6

Error in building installer with InstallShield 2010 Stand Alone Build

I have a web installer that build and runs successfully with InstallShield build exe i.e.
"C:\Program Files\InstallShield\2010\System\ISCmdBld.exe"

However, when I build the installer using InstallShield 2010 Stand Alone Build,

"C:\Program Files\InstallShield\2010 StandaloneBuild\System\ISCmdBld.exe"

It builds installer fine. But when I run the installer, it fails to create website and application pool on IIS-7 on Windows Server 2008. Please help with any fix.
Log file shows:

Setting property 'accessPolicy' to value 'Script, Read' for element 'system.webServer/handlers'. Old value: '513'. m_sSectionName : 'system.webServer/handlers'.
InstallShield 14:45:21: getvaluelog
InstallShield 14:45:21: put_value succeeded. get_StringValue now returns '0' with string value 'Read, Script'.
InstallShield 14:45:21: CommitChanges for path 'MACHINE/WEBROOT/APPHOST/Default Web Site/ImageServerWeb' and physical path 'C:\L1\Production\IS\Web\'.
InstallShield 14:45:21: CommitChanges failed with the following HRESULT: '-1072894420'.

Labels (1)
0 Kudos
(5) Replies
Level 2

Did you ever determine what was causing this error. I am having the same issue and I am having a hard time determining what is causing the problem. The setup works on all our internal servers but is failing on a client server.

0 Kudos
Level 6

Not solved exactly but I have few more observations.

This issue surfaces if MSI package is built on XP system and then run on windows server 2008. Some how, this installer doesnt have required access level to write IIS settings.If I remove web.config from setup package, it installs fine.
Installer creates a default web.config file.

Some access/permissions issue. If you get any help, please do share the solution.

0 Kudos
Level 8

make sure your Installers are set to require administrative priviledges if you are planning on making those kinds of changes.

I have not worked with server 2008 myself yet, but from my understanding it uses a similiar security setup to Vista/Windows7 where even the administrator is running with limited rights unless specified otherwise. It depends on the security settings and policies in place on the server.
0 Kudos
Level 6

When I run the installer. I run it as "Run as administrator". But problem still exists.

When I build installer on my machine, it runs fine. When I build installer on another machine which is XP, it doesn't run correctly on my machine.

14:45:21: CommitChanges failed with the following HRESULT: '-1072894420'.

If I delete the web.config, and run installer then installation is successful and website is create with a new default website.

So error somewhat relates to web.config.
0 Kudos
Level 16

Did you ever find out more on this situation? I have a user running Vista with an installer built using IS2009 and I'm seeing this error code.
0 Kudos