cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
gknierim
Level 6

Error 27506 -

I am getting this error when the install tries to create the database in the Program Files folder. If I make the installation directory other than the Program Files, the installation works and the database is created.

How can I get it so that I can install the program in the Program Files directory along with the databases? I am using text replacement in my SQL script using the INSTALLDIR so it has to be a security issue. This is when I try to install on Windows 7 32 Bit.

This is an InstallScript MSI project.

Thanks,
Greg
Labels (1)
0 Kudos
5 Replies
hidenori
Level 17

Have you checked this thread?
0 Kudos
gknierim
Level 6

I must have missed that one in my search.

So, it is working now. I changed the account that MSSQLSERVER was running under from Local Service to Local System and I was then able to install my program in the Program Files folder as well as creating the database files in the Program Files folder.

Thanks again!
0 Kudos
apatravali
Level 2

gknierim wrote:
I am getting this error when the install tries to create the database in the Program Files folder. If I make the installation directory other than the Program Files, the installation works and the database is created.

How can I get it so that I can install the program in the Program Files directory along with the databases? I am using text replacement in my SQL script using the INSTALLDIR so it has to be a security issue. This is when I try to install on Windows 7 32 Bit.

This is an InstallScript MSI project.

Thanks,
Greg



Hi,

I am getting the same error while running sqlscript to create the databases. Can someone please provide me the solution.

Thanks in advance.
Akshay
0 Kudos
apatravali
Level 2

hidenori wrote:
Have you checked this thread?


Hi Hidenori,

I am getting the same error.

The solution mentioned is to change MSSQLSERVER account settings from Local Service to Local System.

Can you let me know how to do that if that is the correct solution.

Thanks in advance.
Akshay
0 Kudos
hidenori
Level 17

Here is what you need to do:
[LIST=1]
  • Lauch the Microsoft SQL Server Configuration Manager.
  • Click on the SQL Server Services node in the SQL Server Configuration Manager tree.
  • Find the service for the SQL Server instance that you want to configure from the right pane.
  • Right-click on the service and select Properties from the context menu.
  • Change the Built-in account setting from 'Nerwork Service' to 'Local System' in the Log On tab and restart the service.
  • 0 Kudos