cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
marcovdlinden
Level 4

DialogSetInfo not working on installscript

I added this piece of code in my script

function OnBegin( )
STRING test;
NUMBER nResult;
begin
nResult = SdInit ();
NumToStr ( test , DialogSetInfo(DLG_INFO_ALTIMAGE, "C:\TEMP\Untitled.bmp", TRUE) );

MessageBox(test,SEVERE);
end;


What this does is, just remove the default image (both the icon on the left side and the banner image, so it does something), but does not place my selected image. The return value is always 0, so no errors... not even when I change the file name to one that realy does not exist.

Untitled.bmp is a 55x55 24bit bitmap.

I tried various locations of the image (including in SUPPORTDIR ^)
I tried skins and "Slate" same result for both.


Can anyone tell me what I'm doing wrong?
Labels (1)
0 Kudos
4 Replies
RobertDickau
Flexera Alumni

In InstallScript strings, you'll want to enter \\ for each single backslash. The \t value might be expanding to a tab character.

Perhaps first try this as an argument---

"C:\\TEMP\\Untitled.bmp"


Then try copying the bitmap into the Support Files view and using the expression---

SUPPORTDIR ^ "Untitled.bmp"
0 Kudos
marcovdlinden
Level 4

Thanks for the answer.

even changing to \\ does not work. 😞

and your second sugestion I already tried, to no avail.

Thats why I test with a fixed location now, since I dont get an error code on an incorrectly named file, now I know that the problem is not some coversion from SUPPORTDIR or the image not being added to the setup or anything like that.
0 Kudos
RobertDickau
Flexera Alumni

Can you open the bitmap with (and save from) MS Paint? Sometimes the issue is caused by a different bitmap format created by a different application.
0 Kudos
marcovdlinden
Level 4

Solved it,

I assumed it was a 24bit bitmap...
since I opend them in paint and saved them as 24bit bitmap, (from 32bit)
But apperantly paint does not convert it.... only when you chose 8bit it actualy does something.

Used Gimp to make the originals 24bit and everthing worked fine.
Some error codes would have been nice though 🙂
0 Kudos