cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
kevinm123
Pilgrim

DLL installs then disappears a few seconds later

I am using visual studio pro 2010 and Install Shield LE ( Limited Edition ). I have a project that references a 3rd party DLL.

When I run the msi file and watch the install directory, I see the DLL in question get copied and then removed right away.

What's worse is if I do a repair install using add/remove programs in windows, the stuff.dll does get put where it belongs. It only removes the dll on upgrade

I have tried everything I can think of to fix the problem.

I did verbose logging of the install and I found this near the end:

MSI (s) (EC:74) [14:55:22:743]: Executing op: FileRemove(,FileName=ChilkatDotNet2.dll,,ComponentId={BB62B6A6-0558-46B9-B9B6-32B8F502AEB9})
RemoveFiles: File: ChilkatDotNet2.dll, Directory: C:\dcs\backups\



I am fairly inexperience in developing install shield solutions so any help would be greatly appreciated.
0 Kudos
1 Reply
Flexera Ken536
Flexera

Re: DLL installs then disappears a few seconds later

Hi,

Did you re-sequenced the RemoveExistingProducts in the Upgrade paths view?
0 Kudos