cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Andreas_Franz
Level 3

Admin Setup fails

Hi experts,

I’m using InstallShield 2012 (Service Pack 1) to build a simple Setup.exe. The Project based on „Basic MSI Project“ and installs some DLLs and the Microsoft redistributable for Visual Studio.

One of my basic Tests is to extract setup.exe (with setup.exe /a) to check included DLLs. During Extraction I get following Error:

“Database D:\temp\.msi. Cannot open database file. System error -2147287008”.

In Windows explorer I can see the database under D:\temp\.msi”. It’s also possible to open “D:\Temp\.msi” with Orca.

After confirm message above, “D:\temp.msi” will be deleted – and nothing is extracted.

Does anybody have any help or advice on what my next step should be? Thanks in advance.

Andreas

Logfile is attached as zip file.
Labels (1)
0 Kudos
2 Replies
Andreas_Franz
Level 3

Hello everybody,
we solved the problem. Our IT Department installed las week a new version of our Antivirus Software (TrendMicro). The new scan engine has a performance impact and need much more time for file scanning. Now we are back to "old" engine and everything is fine.

Kind Regards
Andreas
0 Kudos
Roli_Weber
Level 2

Hi
I work with Installshield 2011 Premier Edition
I have a multilanguage Basic MSI Project
I build my setup with ISCmdBld.exe or with ISBuild.exe or from IS Studio alwas the same error.
If I turn on all UI Languages in Releases\MyRelease i got the error. If I turn on only one Languge no errors!

Logfile with error:

ISDEV : fatal error -6040: Internal build error
Windows Installer Error 2203: C:\....\....msi, -2147287008
MsiOpenDatabase(C:\...\....msi)

the meanig of HR code -2147287008 (0x80030020) : is sharing violation !

Solution:
Disable the TendMicro Antivirus solve the error!

Roli
0 Kudos