4354 warning (unable to extract COM information) in IS 2015 LE / Win10pro 64bit

Extract COM information from my 32-bit-DLL fails with warning 4354; tried all the possible resolutions/hints I found on the web (turn UAC on, checking dependencies, regsvr32 runs fine with the dll, IsCmdBld.exe (compatibilty settings) does not exists in IS2015LE).

My machine is Windows 10 64Bit Pro, VS 2013 SP5 (run as admin), InstallShield 2015 Limited Edition.

How can I fix this?
Labels (1)
Tags (2)
0 Kudos
4 Replies

Upgrade from 2013 to 2015 caused the problem for me

I recently upgraded from Visual Studio 2013 to 2015 and therefore upgraded from InstallShield Limited Edition 2013 to InstallShield Limited Edition 2015. On every project that requires installing COM dlls, I now get the following error:
warning : -4354: The build was unable to extract COM information from the file xxx.dll in component xxx.dll. Please ensure that the file is self-registering and verify that the self-registration process does not fail.
I am running as administrator and the dll's worked as self registering with 2013.
I am running Windows 7 64-bit and they are 32 bit dlls.

I haven't found a resolution yet.
0 Kudos
Active participant

InstallShield 2015 COM extraction on Windows 10 x64

Same issue for me...

Seen this issue before using InstallShield 2013 Professional on Windows 10 Enterprise x64. I assumed it was solved by switching to the most
recent version of InstallShield. Unfortunately not. It's a clean machine with a fresh Windows 10 installation on it.

COM extraction seems to function quite good on Windows 7 x64, it does something on Windows 8.1 x64 and nothing at all on Windows 10 x64.
To complete the information: InstallShield 2015 was used on Windows 7 and 10 (as I mentioned before) and InstallShield 2013 on Windows 8.
I used the same InstallShield projectfile and performed the operation on the same component.

"COM extract at build" and "Extract FOM Data for Key File" both fail. The first one gives an error during the build process. The second one
delivers no outputdata.

How can this issue be solved?
0 Kudos

Solved after installing anniversary update

After installing the anniversary update for Windows 10 (1607) the problem seems to be gone, COM-Extraction is now successful.
0 Kudos
Flexera beginner

Re: Solved after installing anniversary update

This problem still exists for me using InstallShield 2018 Express and Windows 10 Pro 1903. I have altered the IsCmdBld compatibility settings. I have run InstallShield 2018 Express as Administrator . I always have UAC turned on. I've checked the Dependencies, and they are only Windows libraries that are part of the OS.

Is there any way to see why this warning is occurring?

NOTE: I am seeing "mscorsn.dll has been obsoleted. Please use mscoree.dll for Strong Name APIs." message from Isdev.exe in the OS debug output when building my installer.

0 Kudos