ramalaks
Level 6

silent install?

how to do the silent install of my installer? i am using IA 8.0.1 enterprise.
thanks
Labels (1)
0 Kudos
11 Replies
scully13
Level 4

From Advanced Designer go under: Installer UI -> Look & Feel then under the General UI Settings tab make sure the Silent check box is checked. Then from a command line launch it something like this: "install.exe -i silent"
0 Kudos
ramalaks
Level 6

how do i know the success/failure of the silent install..?
0 Kudos
pv7721
Level 20

You could check for instance the creation of the installation log (this is the last thing created by a successful installer).
0 Kudos
ramalaks
Level 6

I tried silent install. in the add/remove program my installer products size shown is very small than what i see installer thru gui?
why?
0 Kudos
ramalaks
Level 6

also noticed that in the install log, some of the actions are null and successful.
very confusing..
0 Kudos
RobertDickau
Flexera Alumni

Depending on your build settings, you might also be able to check the installer's exit code.

(As an aside, for IA 8.x issues, you might consider posting to that version's forum...)
0 Kudos
pv7721
Level 20

Ramalaks, just a question: enablig the installer silent mode is not enough. You also need an installer.properties file with variables holding values that are normally populate through panels / consoles. Do you that?
0 Kudos
ramalaks
Level 6

yes i do have installer.properties files that only has the below

# Wed Apr 16 12:21:17 EDT 2008
# Replay feature output
# ---------------------
# This file was built by the Replay feature of InstallAnywhere.
# It contains variables that were set by Panels or Consoles.



#Choose Install Folder
#---------------------
USER_INSTALL_DIR=D:\\Program Files\\Nortel

#Restart Windows
#---------------
USER_INPUT_RESULT_5=0
USER_INPUT_RESULT_10=1

the silent install did not work right.
0 Kudos
ramalaks
Level 6

RobertDickau wrote:
Depending on your build settings, you might also be able to check the installer's exit code.

(As an aside, for IA 8.x issues, you might consider posting to that version's forum...)



this forum is read only
0 Kudos
ramalaks
Level 6

BTW what is the diff between

$USER_MAGIC_FOLDER_1$\deploy\jboss-web.deployer\server.xml



$USER_MAGIC_FOLDER_1$/$deploy$/$jboss-web.deployer$/$server.xml

using additional $ in the directory format?
0 Kudos
pv7721
Level 20

Using $/$ insures that it is always correctly translated into / or \, according to the platform you're installing to. And if you relied on the auto-generated installer.properties file, it might be missing variables.

Also the forum indicated by Robert is not at all read-only, actually it's a subforum on these forums which is dedicated specially to versions prior to IA 2008 (it's an extension of the ZeroG Community forums if you want), because the forum where you posted it's for IA 2008, but you have IA 8.0.1.
0 Kudos