cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
PassinThru
Pilgrim

Japanese License in License Panel

Hi -

I'm trying to display a Japanese version of our product license agreement during the install in the license agreement panel. I've succeeded in getting it to display on Japanese installs on both Windows and Linux. On Linux, it looks great. On Windows, it does not display correctly at all.

The file is a UTF-8 file, but the Windows panel doesn't recognize it as such. The Linux panel shows it fine.

How do I get InstallAnywhere on Windows to display the file correctly?

- Scott
Labels (1)
0 Kudos
10 Replies
Masudkhan
Pilgrim

Re: Japanese License in License Panel

If I am not wrong, you have to change your windows system locale to Japanese.
0 Kudos
PassinThru
Pilgrim

Re: Japanese License in License Panel

I agree, and our machines are set to the Japanese locale. But the problem persists.
0 Kudos
Masudkhan
Pilgrim

Re: Japanese License in License Panel

Could you please post a snap shot of the screen?
0 Kudos
PassinThru
Pilgrim

Re: Japanese License in License Panel

Sure. Here's the installer running on Linux:



And here's how it looks on Windows 7:



The display on Windows is identical to what I see when I type it out on Windows, i.e., the text is treated as ANSI. But the IA docs say files are treated as UTF-8 by default. I had hoped that would mean it would display correctly, but clearly not.

- Scott
0 Kudos
Masudkhan
Pilgrim

Re: Japanese License in License Panel

Yes there seems to be a difference in chars displayed.
I think it is some thing to do with the OS rather than IA.
I'm sorry, i have run out of ideas.
My sincere apologies for not being of any help to you.
0 Kudos
pv7721
Flexera beginner

Re: Japanese License in License Panel

Maybe that was an issue with IA 2011. Have you tried to rebuild your installer with IA 2012, in order to see if you reproduce the issue?
0 Kudos
PassinThru
Pilgrim

Re: Japanese License in License Panel

pv7721 wrote:
Maybe that was an issue with IA 2011. Have you tried to rebuild your installer with IA 2012, in order to see if you reproduce the issue?


No, not yet. We'll be moving to 2012 at the end of the month, and I'll try it again with that. Thanks for the suggestion.
0 Kudos
jerome_IA
Flexera beginner

Re: Japanese License in License Panel

Hi,

I'm having the exact same issue using InstallAnywhere 2013 version.
Works well on Linux but not on Windows.

Did you (or anyone else) got a solution for this issue?

--Jerome
0 Kudos
jerome_IA
Flexera beginner

Re: Japanese License in License Panel

Ok, running some more tests, it looks like it works well with HTML files but not with TEXT files.

So I'll use html license agreements
0 Kudos