cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

Issues of upgrading from IA8.0 to IA2009.

Hi,

We used IA8.0 for our previous product release and is planning to upgrade to IA2009.

We downloaded an evaluation version of IA2009 and tried to build previous IAPs with it. During this process, we found some strange problems:

#1 installer hang while creating shortcuts on WinXP os (SP2);

#2 on non-windows os, there's an extra folder created in install dir which is of the same dir structure with shortcut folder, and it's not created in a IA8.0 build.


We made some investigation on our side and found that:

for issue#1: we can workaround it by choosing another shortcut icon file (of the same size and same format with old ones). The previous icon works pretty well in IA8.0, but just doesn't work in IA2009;

for issue#2: IA creates magic folders automatically during install time, no matter whether there's file in it. In IA8.0, we add platform check rules on it to force it only creates on Windows OS, yet in 2009, seems that these rules doesn't work. Is it caused by we're using an evaluation version?

Any of your kindly help is much appreciated.
Labels (1)
0 Kudos
5 Replies
Highlighted
Pilgrim

Re: Issues of upgrading from IA8.0 to IA2009.

Did I post to a wrong sub-forum? If so, could anyone please kindly tell me where should I post this to?
0 Kudos
Highlighted
Pilgrim

Re: Issues of upgrading from IA8.0 to IA2009.

xzhang wrote:

for issue#2: IA creates magic folders automatically during install time, no matter whether there's file in it. In IA8.0, we add platform check rules on it to force it only creates on Windows OS, yet in 2009, seems that these rules doesn't work. Is it caused by we're using an evaluation version?


We have encountered the same problem with the full version of IA 2009. Annoying, isn't it?
0 Kudos
Highlighted
Pilgrim

Problems upgrading to IA 2009

I too have encountered quite a few problems upgrading to IA 2009 from IA 7.1
- I get a null ptr exception when I click the uninstaller
- on one of my simple gui panels, the last element in the list is no longer visible
- my billboards are no longer centered during the install step, they are too the right

I must admit I am a bit frustrated. We need Windows 2008 support, so I had to make the switch.

I filed support cases for the issues that I have encountered so far.
0 Kudos
Highlighted
Pilgrim

Re: Issues of upgrading from IA8.0 to IA2009.

xzhang wrote:

for issue#2: IA creates magic folders automatically during install time, no matter whether there's file in it. In IA8.0, we add platform check rules on it to force it only creates on Windows OS, yet in 2009, seems that these rules doesn't work.


There is a work round for this problem. Set up an action to set the magic folder variable to $DO_NOT_INSTALL$, and put your platform check rule on that action.
0 Kudos
Highlighted
Pilgrim

Re: Issues of upgrading from IA8.0 to IA2009.

xzhang wrote:


#1 installer hang while creating shortcuts on WinXP os (SP2);

...

for issue#1: we can workaround it by choosing another shortcut icon file (of the same size and same format with old ones). The previous icon works pretty well in IA8.0, but just doesn't work in IA2009;


Did you ever get a resolution for Issue #1? Just ran into it myself, and it's on an icon which was working with IA 2009 a week ago. The content of the application changed, and no I run into the problem creating a shortcut. With console turned on, I get the following repeating error:

Image still not fully loaded: width < 0
0 Kudos