cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
kosimosi
Level 3

Focus problems in User Input Panel on X redirection

Hello

We are using InstallAnywhere 2011 SP3 and have recently updated the bundled java from java 6 update 29 to java 7 update 5.
The problem we have now is, that during the installation process, in User Input Panels its not possible to click into the text-fields anymore. So, you have no chance on entering anything there.
Also the License Agreement takes really minutes to display!

This happens, when we install on linux / solaris machines, with the x redirected to Windows or linux desktop machines.

I have seen, that in java 7 there are some changes on the focus implementation. (See e.g. http://stackoverflow.com/questions/10230006/focus-problems-with-jdk7-and-native-components)

How can this be solved, without going back to java 6?

Btw. I have seen some release notes on IA2011 SP4, that would also fix a bug we are currently running into. Where can I find the bits to download it. If I do a "check for updates" in Installanywhere it says no new versions found.

Thanks in advance.
kosimosi
Labels (1)
0 Kudos
3 Replies
jerome_IA
Level 9

I do not know about your focus issues, but you may be able to download SP4 after login to this page: https://flexerasoftware.subscribenet.com/control/inst/index

--Jerome
0 Kudos
kosimosi
Level 3

Hello Jerome

Thanks for your reply. I was able to enter the downloadcenter with the link you mentioned. It seems, as we don't have a support contract, we cannot get the new SP4, and have to stick with SP3?

Concerning the focus problems, I founf out, that if you use the "Windowed mode with DWM", and the X11 server and DWM desktop are running in a container window, it is working.

This is not super nice, but at least somehow a workaround.

Greets
kosimosi
0 Kudos
kosimosi
Level 3

Hello

Just to finish this up, we found out, that this is a confirmed java bug. Easily reproducable by any swing application with JTextField and xming-Servers on Windows.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7029051.

As a further workaround you can use:

Xnest :3 &) && DISPLAY=:3 /tmp/install.bin && killall Xnest


Best regards
kosimosi
0 Kudos