pavan_kumar_ds
Level 5

Choose Install folder !!

Hii friends,

Am using choose install folder in the pre-installation task and while running the exe,even if i change the path to c:\nameoffolder,its taking default path as c:\programfiles\nameoffolder. How can i change this ????
Labels (1)
0 Kudos
6 Replies
manzoor_matoo
Level 4

Hello Pavan,

I am able to install the install.exe on different location by "choose the installer folder" in the pre-installation phase. Make sure you have given a path properly.
I have installed the installer on D:\test_installer location.

Please let me know if it works.
Thanks,

Manzoor
0 Kudos
pavan_kumar_ds
Level 5

Hello mansoor,

Yeah its working fine i had done small mistake:)Thx for ur reply anyways!
0 Kudos
scarney
Level 5

Hello,

I am also trying to change the default install folder to something other than C:\Program Files\MyProduct.

[LIST=1]
  • Config:
    [LIST=a]
  • InstallAnywhere 2012 SP1, Enterprise
  • Windows SP, SP3

  • Try setting system drive root using drop-down menu
    [LIST=a]
  • Bring up Advanced Designer
  • Goto Pre-Install task
  • At the top is a drop-down menu plus entry dialog entitlled 'Default Install Folder'
  • In the drop-down menu I selected 'System Drive Root'( I presume that means C: )
  • Rebuilt Installer
  • Ran it. Default: C:\Program Files\MyProduct

  • Try setting it using a magic folder
    [LIST=a]
  • Bring up Advanced Designer
  • Goto Pre-Install task
  • Set $USER_MAGIC_FOLDER_8$to C:\MyProduct
  • In Pre-Install task, I did a 'Add Action' -> 'Set InstallAnywhere Variable - Single Variable'
  • I set $USER_INSTALL_DIR$ to $USER_MAGIC_FOLDER_8$
  • Rebuilt Installer
  • Ran it. Default: C:\Program Files\MyProduct

  • Try setting default install root to a user magic folder in the drop-down menu
    [LIST=a]
  • Bring up Advanced Designer
  • Goto Pre-Install task
  • Set $USER_MAGIC_FOLDER_8$ to C:\MyProduct
  • At the top is a drop-down menu plus entry dialog entitlled 'Default Install Folder'
  • In the drop-down menu I selected $USER_MAGIC_FOLDER_8$ ( I presume that means C:)
  • Rebuilt Installer
  • Ran it. Default: C:\Program Files\MyProduct



    BTW: In the 'Project' task is an area entitled 'Windows Execution Leve'. I set that to 'Administrator' just in case.

    What am I missing :confused:

    --
    Regards,
    Sandra Carney
  • 0 Kudos
    pavan_kumar_ds
    Level 5

    Hellooo,

    Go to project-platforms-windows- select system drive Root\$PRODUCT_NAME$ ,hope this will solve the problem.
    0 Kudos
    scarney
    Level 5

    In my post from 15-Apr-2013, I forgot to mention that I also tried a couple of other things:

    [LIST=1]
  • System Drive Root
    [LIST=a]
  • Went to 'Project' task
  • Selected the 'Windows' tab
  • In the 'Default Install Folder' section, I selected System Drive Root from the menu.
  • Result: default install folder is still [I/]C:Program Files\MyProduct

  • Then I ran through the above actions with the default set to $USER_MAGIC_FOLDER_8$
  • Same result: Default install folder is C:\Program Folders\MyProduct
  • One other thing to note. I originally configured the Project/Installer to deploy to the InstallAnywhere default which is 'C:\Program Folders\MyProduct'. Now I want to change it. Is that my problem? Do I have to start a new installer project to do this?
  • 0 Kudos
    scarney
    Level 5

    Hello,

    This is what I did:

    [LIST=1]
  • In the Pre-Install task, I assigned C:\MyProduct to $USER_MAGIC_FOLDER_1$ before I did anything else.
  • Then I selected Project -> Platforms -> Windows
  • Then in the area entitled Default Install Folder, I selected $USER_MAGIC_FOLDER_1$ from the dropdown menu. I entered nothing in the entry dialog.
  • That works.
  • NOTE: If you don't define $USER_MAGIC_FOLDER_1$ or whatever magic folder you want, first, it won't work because the thing has already been assigned. It doesn't seem to allow people to go back and do this stuff later in the project 😞
  • 0 Kudos