Supported web browsers

Supported web browsers

Question:

Which web browser should I use when navigating the Portal?

Answer:

We have found that web browsers such as IE or Edge can be buggy with our Platform and may not properly work from time to time.  For this reason, we recommend and support the latest version of either Google Chrome or Firefox. If you are already using a recommended web browser, please ensure the version is the most up to date.

You may also attempt to use a Google Chrome Incognito session or a Firefox Private session to navigate to the Portal.

Labels (3)
Was this article helpful? Yes No
No ratings
Version history
Revision #:
1 of 1
Last update:
‎Jan 14, 2021 11:49 AM
Updated by:
 
Contributors