cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to start the License deamon with error "/lib64/libc.so.6: version `GLIBC_2.14' not found " Due to Older Version Installed

Unable to start the License deamon with error "/lib64/libc.so.6: version `GLIBC_2.14' not found " Due to Older Version Installed

Summary

Unable to start the License deamon with error /lib64/libc.so.6: version `GLIBC_2.14' not found.

Symptoms

Can?t start the license deamon: vendor deamon indicate that we need latest license manger.
Error log:
*******
cameo: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by cameo)
16:00:05 (lmgrd) cameo exited with status 1 signal = 17
16:00:05 (lmgrd) Since this is an unknown status, license server
16:00:05 (lmgrd) manager (lmgrd) will attempt to re-start the vendor daemon.
16:00:05 (lmgrd) REStarted cameo (internet tcp_port 47531 pid 29739)
cameo: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by cameo)
16:00:05 (lmgrd) cameo exited with status 1 signal = 17
16:00:05 (lmgrd) Since this is an unknown status, license server
16:00:05 (lmgrd) manager (lmgrd) will attempt to re-start the vendor daemon.
16:00:05 (lmgrd) REStarted cameo (internet tcp_port 34258 pid 29743)
cameo: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by cameo)
16:00:05 (lmgrd) cameo exited with status 1 signal = 17
16:00:05 (lmgrd) Since this is an unknown status, license server
16:00:05 (lmgrd) manager (lmgrd) will attempt to re-start the vendor daemon.
16:00:05 (lmgrd) REStarted cameo (internet tcp_port 47413 pid 29747)



Cause

The program was compiled against glibc version 2.14, and it requires that version to run, but your system has an older version installed.

Resolution

Either recompile the program against the version of glibc that's on your system, or install a newer version of glibc (the "libc6" package in Debian).

Additional Information

Labels (1)
Was this article helpful? Yes No
No ratings