cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

HASP issues with Windows 10 Build 2004

HASP issues with Windows 10 Build 2004

We have noticed issues with HASP configuration files reported by Thales as well as Windows.

==============================================================================================================================================

https://supportportal.gemalto.com/csm?id=kb_article_view&sys_kb_id=39f264ea1b981854f12064606e4bcb2f&...

  • Issue #1

When Sentinel LDK Run-time Environment version 7.100 or earlier is installed:
Upgrading the operating system to Windows 10 version 2004 may fail (that is, the installation of Windows may fail, causing the installation to roll back).

  • Issue #2

When Sentinel Run-time Environment is not installed: After upgrading Windows 10 to version 2004, installing Sentinel LDK Run-time version 7.100 or earlier may cause a stop error.

Please also be advised that this issue is only reported where Sentinel LDK Run-time Environment version 7.100 or earlier is already installed or will be installed. In FNO 11.17 toolkit, we have already upgraded this to v7.101 and in R3 release (11.17.1) it will be on v7.103. As per the link provided by Gemalto, they have mentioned issue will be seen in version 7.100 and earlier. So an upgrade (FNP toolkit + driver) would be immediate solution.

============================================================================================================================================

https://docs.microsoft.com/en-us/windows/release-information/status-windows-10-2004?irgwc=1&OCID=AID...

Issues updating or starting up devices when aksfridge.sys or aksdf.sys is present:

An incompatibility issue was found with apps or drivers using certain versions of aksfridge.sys or aksdf.sys and Windows 10, version 2004 (the Windows 10 May 2020 Update). When an affected version of aksfridge.sys or aksdf.sys is present, Windows 10, version 2004 might fail to install or might fail to start after updating. Affected file versions are up to 1.8.0.* for aksfridge.sys or up to 1.51.* for aksdf.sys.
 
To safeguard your update experience, we have applied a compatibility hold on Windows 10 devices with an affected version of aksfridge.sys from being offered Windows 10, version 2004 or Windows Server, version 2004.
 
Affected platforms:
  • Client: Windows 10, version 2004
  • Server: Windows Server, version 2004
 
Next steps: Microsoft is working on a resolution and will provide an update in an upcoming release.
 
Note We recommend that you do not attempt to manually update using the Update now button or the Media Creation Tool until this issue has been resolved.
===========================================================================================================================================

 

Official Support Statement for Build 2004: (valid as of date July 17th, 2020)

"Windows 10 Build 1909 is the latest OS version that FNP supports (as Build 2004 was only made available by end of May 2020) and currently we are not aware of any workaround against the reported issue by MS".

Mitigation:

Since Microsoft has acknowledged to be working on this, hence we can only wait for this to be fixed in future Windows 10 releases. Although from the above URL, Thales has provided the resolution against these observations, which could be tried in the meanwhile to mitigate BSOD/installation issues.

We have confirmed with Thales Support that issue mentioned on MS website is same as the one on Thales one. Any end user availing the HASP RTE of v7.100 or lower will face this issue. With FNP-11.17, the HASP RTE has been upgraded to v 7.101 (to be upgraded further in v11.17.1 release). So, customers are advised to try the latest version toolkit executables with HASP drivers.

Was this article helpful? Yes No
No ratings
Version history
Revision #:
5 of 5
Last update:
‎Jul 16, 2020 10:01 PM
Updated by:
 
Contributors