cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

lmgrd grabs wrong HostID

My lmgrd program is grabbing the IP address from my Dell iDRAC board and thinking that is my HostID.  How can I force FlexLM to use the actual IP address of the computer instead of the iDRAC board?  Thanks.

0 Kudos
5 Replies
Highlighted
Revenera
Revenera

Re: lmgrd grabs wrong HostID

In the license file you can specify the IP Address in the server line.
The syntax of the server line would be SERVER host hostid [port] [PRIMARY_IS_MASTER] [HEARTBEAT_INTERVAL=seconds]

this_host can be used when the host name is unknown. This enables the license
administrator to install the application and start the license server. FlexEnabled
applications on the same host as the license server work fine. FlexEnabled applications
on other systems need to set LM_LICENSE_FILE or VENDOR_LICENSE_FILE to port@host
or @host to find the license server, or this_host can simply be edited to the real host
name.
0 Kudos
Highlighted
Pilgrim

Re: lmgrd grabs wrong HostID

Thanks for the suggestion. We tried that. Didn't work.
The only solution we found was to disable all the network cards except for one, only then would the computer system assign the correct HostID.
0 Kudos
Highlighted
Flexera
Flexera

Re: lmgrd grabs wrong HostID

@kozar2 , the way Flexnet libraries pick up the IP address from particular environment is based on the priority provided by the OS itself. So, if the output of (ipconfig/ifconfig) records particular adapter as PRIMARY, then the associated IP address will be picked up for all the Flex calls.

So, here is what we can do (to mitigate the side effects of it):

- Enable the 'LM_A_PHYSICAL_ETHERNETID' attribute for client application.

If True, lc_hostid returns only Ethernet hostids that are identified as belonging to physical devices and filters out virtual adapter values (such as those installed by VPN software) on Windows platforms. This filtering option is provided because using a virtual adapter as a hostid can cause license failure when the Ethernet identity created by the virtual adapter changes. The default is False, which turns the filtering off for backward compatibility

- Tweak the Automatic Network Matrix for adapters (Please be advised it will affect all the applications on current system).

There are multiple web pages hosted on how to achieve this. For ex: https://www.windowscentral.com/how-change-priority-order-network-adapters-windows-10

We don't advertize any of the methods to tweak the automatic matrix, it is just for your internal testing - based on which you may be enabled to take a decision about implementation in business deployments.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos
Highlighted
Active participant

Re: lmgrd grabs wrong HostID

Maybe you can use a MAC address as a hostid instead of an IP address?

The Flex code knows to search through all available MAC addresses looking for a match.  For some reason it doesn't do this with IP addresses, so you are forced to use the first one.

0 Kudos
Highlighted
Flexera
Flexera

Re: lmgrd grabs wrong HostID

@raffie , your request on adding the similar logic for identifying the multiple IP addresses is in assessment with engineering. TBH, in our internal analysis it shows a serious issue around checkout performance - but its being assessed by the team. So, you should have an update on that as well.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos