cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Nilsson
Level 2

Upgrading LMTOOLS 11.17.1.0 and Windows Server

Good morning,

I am currently discovering Flexera products.

I have two questions to ask about this :

- I have LMTOOLS version 11.17.1.0, which is managing many license services. Is it recommended to systematically update LMTOOLS to the latest version ?
How to proceed ? Are there automatic installers ? Is this risky for running licensing services ? Does this require a service interruption ?

- I need to upgrade Windows Server. What is the latest version of Windows Server that LMTOOLS 11.17.1.0 can support ?
Where can I find compatibility details about LMTOOLS and operating systems ?

Thank you for you precious help,

Good day,

Cordially

(3) Replies
Yvernekar
Level 5 Flexeran
Level 5 Flexeran

Hi,
By upgrade of lmtools do you mean you are planning to upgrade the FNP kit as well ? if yes please refer to the section "Upgrading to a New Toolkit Version" on page 67 of fnp_devenv.pdf.

Where can I find compatibility details about LMTOOLS and operating systems ?
-> The compatibility details for the specific kit are always shared in the respective release notes.
If the kit is supported then Lmtools also supports the OS. 

I have attached the doc lib and the release notes for your reference.

Hi Yvernekar,

First of all, thanks for your reply.

In fact, I just began to know LMTOOLS. I don't know which components are installed on my server.

I use the LMTOOLS program to manage license services, to see the logs and perform diagnostics
(see screenshot in attachment).

It seems that every program has some executables (lmgrd, lmtools, lmutils, you can see screenshots in attachment).

So I don't know if I have the FNP kit as well. I think not. Nevertheless, is it possible to upgrade these files (lmtools, lmgrd, etc) ?

I added another screenshot, in the Control panel I can see a program called FlexNet Publisher 64-bit License Server Manager. So maybe I need to upgrade it as well ?

Thank you for your help,

Cordially,

0 Kudos

Hi, 

Lmtools is just a UI interface for the lmgrd server as a result to upgrade you have to update the other components as well. 
It would be better if you could raise a support case with us so that we can jump on a call to clarify all of your doubts. Once raised please update me with the case number.

KB on How to raise a support case:
https://community.flexera.com/t5/Community-How-Tos/How-to-Open-a-Case-with-Support/ta-p/96038

KR,
Yashwanth

0 Kudos