jwang_ga
Flexera beginner

Invalid (inconsistent) license key. (-8,544)

We are migrating from FNP 11.8.0 to FNP 11.14.1.3.  Everything seems fine except when running older versions of the application against the new license server, the error of Invalid (inconsistent) license key. (-8,544) occurs. 

We did modify the makefile by changing lmgri_trl to lmgri per the KB article "Error "invalid license key (inconsistent authentication code)" seen when building toolkit with 11.13.1."  However, it still does not work.

Any suggestions or help will be greatly appreciated.

jwang

0 Kudos
3 Replies
aparashar1
Flexera Alumni

@jwang_ga , could you confirm if the lm_code.h with which the latest server and older client is built are exactly same?

This error could be seen when there is a difference in "LM_STRENGTH " in both the lm_code.h

Kindly recheck the same.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos

@aprashar1, at your suggestion, I checked the lm_code.h files, they are different in LM_STRENGTH.  I modified the new version to match the old one. It worked.  Thank you  much for your help.

By the way, if I migrate to the latest version FNP 11.16.5.1 and follow the same approach, will it still be compatible with the application compiled with FNP 11.8.0?  Or is there additional changes that I need to make?

Many thanks.

jwang

 

 

0 Kudos

@jwang_ga , i am glad to hear that.

FNP toolkit maintains the backard compatibility rule, so you should be fine with following the same approach for v11.8 client and the latest server.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos