cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
DragonDave
Pilgrim

Getting "Invalid key data supplied" when building Flex library

Hi. I'm trying to build the Flex libraries for 64-bit for the first time (32-bit builds fine). But I'm getting the following error at the start of build. It's built lmnewgen and executing it, but the execution is failing.

if exist lm_new.c del lm_new.c
lmnewgen.exe
v8.1+ FlexNet, using TRL
lc_init failed: Invalid key data supplied.
FlexNet Licensing error:-44,49
NMAKE : fatal error U1077: '.\lmnewgen.exe' : return code '0x1'
Stop.

One suggestion I had was that we hadn't purchased a 64-bit license. However, our receipt from Flexera indicates that we'd puchased both 32-bit and 64-bit support.

Any suggestions would be appreciated. We've logged a support request with Flexera, but I'm getting old waiting on a reply.

Thanks...
Labels (1)
Tags (4)
0 Kudos
1 Reply
Flexera Aparashar
Flexera

Re: Getting "Invalid key data supplied" when building Flex library

Hi Dave,

Primarily it seems to be the case where the the VENDOR_DATA or seeds do not seem to be compatible with the platform.
Could you share the platform details and steps that you have followed to build the kit?
Also, did you hear back from the Flexera Support about the support ticket you had raised?

Regards,
Abhay
0 Kudos