cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
shriramcs
Flexera beginner

FlexLM backward compatibility

Hello,

I have 3 questions.

1. My license generator was built with FlexLM 10.1 and client with 11.14.1. I upgraded my client application to FlexLM 11.14.1.3 and it stopped working. It thew LM_BADCODE error which maps to "Bad encryption code". Then I upgraded my license generator application from 11.4.1.3 and everything stated working. So, Is it necessary to upgrade the license generator to use this version of FlexLM?

2. If I upgrade my license generator, will the file generated with upgraded FlexLM be compatible with old client application of FlexLM? Is there any flag to make it backward compatible? It is a tedious process to re-share the license files to customers.

3. I noticed a significant improvement in time taken to checkout the license when I upgraded both license generator(from 10.1 to 11.14.1.3) and client (from 11.14.0.1 to 11.14.1.3). Have you made and performance improvement while transitioning to this version?

Best Regards,

Mohan.

0 Kudos
1 Reply
Flexera cfischer
Flexera

Re: FlexLM backward compatibility

Hi, the rules about FLEXnet Publisher component version compatibility are:

• Version of lmutil/lmtools must be >=

• Version of lmadmin or lmgrd, which must be >=

• Version of vendor daemon, which must be >=

• Version of the client library linked to the FlexEnabled application, which must be >=

• Activation utility, which must be >=

• Version of license file format.

0 Kudos