jjardine
Flexera beginner

FNP 11.14.0.2 used with VPN (Zscaler Private Access) failed due to ICMP/Ping request

Hello,

A lot of home office are deployed as you can imagine and I have some of our final Customers they used VPN connection managed by this product Zscaler Private Access for high security reason. The consequence is the Flex request between our software and their Flex server is blocked/failed. After their own investigations they write me that this is due to the ICMP level requests (ping...) which is blocked by Zscaler Private Access. Is there a solution to solve this issue ?

Thanks in advance for your support.

0 Kudos
8 Replies
aparashar1
Flexera Alumni

Re: FNP 11.14.0.2 used with VPN (Zscaler Private Access) failed due to ICMP/Ping request

@jjardine , FNP toolkit has dependency on ICMP protocol only for license finder box in Windows platform.

Is license finder box a part of the your native solution and a mandatory to have one? If not, then you can disable the pop up by setting attribute LM_A_PROMPT_FOR_FILE to 0 :
lc_set_attr(lc_job, LM_A_PROMPT_FOR_FILE, (LM_A_VAL_TYPE) 0);

If it is a mandatory part of your implementation and you can not avoid it, then i am afraid it must be allowed to process through.

Let me know if that helps.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos
jjardine
Flexera beginner

Re: FNP 11.14.0.2 used with VPN (Zscaler Private Access) failed due to ICMP/Ping request

Answer to your questions:

+ FNP toolkit has dependency on ICMP protocol only for license finder box in Windows platform.

-> Yes, we provide only Windows FNP Tool.

+ Is license finder box a part of the your native solution and a mandatory to have one?

-> Yes

 

0 Kudos
aparashar1
Flexera Alumni

Re: FNP 11.14.0.2 used with VPN (Zscaler Private Access) failed due to ICMP/Ping request

@jjardine , thanks for the confirmation.

I am afraid in such a case, you would need to fix the Server IP and Port and add it as LICPATH under the client application. If the ICMP is disabled, then that would be recommended way.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos
jjardine
Flexera beginner

Re: FNP 11.14.0.2 used with VPN (Zscaler Private Access) failed due to ICMP/Ping request

In our software Client side we set the flex server by defining <port number>@<Hostname> in the User Interface at first and this information is saved in a Xml file. And when we execute our product it checks this Xml file to know where the request of license must be adressed.

Do you mean that in this setting we have to replace the <Hostname> value by the IP address of license server ?

image.png

0 Kudos
aparashar1
Flexera Alumni

Re: FNP 11.14.0.2 used with VPN (Zscaler Private Access) failed due to ICMP/Ping request

@jjardine , the shared screenshot seems to be a piece of your custom implementation.

Have you considered setting the VENDOR_LICENSE_FILE attribute (that points to license server location OR a local copy of license file), that may avoid setting the ServerName through UI (in results no ICMP restriction affecting the license search)?

You can either set it using utilities (i.e. lmutil lmpath) or an entry under registry "Computer\HKEY_CURRENT_USER\SOFTWARE\FLEXlm License Manager" for VENDOR_LICENSE_FILE with 'port@host' details.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos
jjardine
Flexera beginner

Re: FNP 11.14.0.2 used with VPN (Zscaler Private Access) failed due to ICMP/Ping request

Hello,

It is not enough clear for me, where we set this attribute LM_A_PROMPT_FOR_FILE ?
- On User computer ?
- On license server ?
- Is it a Windows settings ? environment variable, oprion file ... ?
or
- In the source code of our software part on the license management ?

Thanks in advance

 

0 Kudos
jjardine
Flexera beginner

Re: FNP 11.14.0.2 used with VPN (Zscaler Private Access) failed due to ICMP/Ping request

Hello

How you do that ?

"you would need to fix the Server IP and Port and add it as LICPATH under the client application"

Can you give me some examples to ut in place ?

Thanks in advance

0 Kudos
aparashar1
Flexera Alumni

Re: FNP 11.14.0.2 used with VPN (Zscaler Private Access) failed due to ICMP/Ping request

@jjardine 

It is not enough clear for me, where we set this attribute LM_A_PROMPT_FOR_FILE ?

[Abhay]: This attribute is set through the client application, which performs the license checkout.


The recommendation is to have an environment variable "VENDOR_LICENSE_FILE" (replace VENDOR keyword with your native vendor daemon name) to port@host configuration. Where port is the TCP port at which license server is running and 'host' could be hostname/IP address of server system.

 

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos