cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Intrepid explorer

Having issue trying to set public key again

Jump to solution

Hi,

I don't know why I can't set my Public Key  in Production Producer Portal. The public key is already set in UAT. I am using the same one. It is returning error 405.

In Postman:

URL

https://flexXXXX-ns.flexnetoperations.com/operations/api/updates/update-authorization-key

Authorization is basic with User id and password. I checked that password works again.

Headers- file attached

Body- file attached (public key) no red shows in Postman for syntax issues.

What is also interesting is that I cannot set the public key either in the UAT environment, even though I don't want to change the value.

Please advise. We are getting very close to our goal.

Thank you,

Ken

 

 
 

 

 

0 Kudos
1 Solution

Accepted Solutions
Intrepid explorer

Re: Having issue trying to set public key again

Jump to solution

Hi Jim,

That URL does work.

Thank you for helping on a Saturday !!!!!

You are awesome Jim!

View solution in original post

0 Kudos
9 Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

Re: Having issue trying to set public key again

Jump to solution

Hi Ken,

I'm not seeing any issue with my Production/UAT Sites.   Please submit a support ticket so that someone with access can help you.

Thanks,

Jim

Intrepid explorer

Re: Having issue trying to set public key again

Jump to solution

Hi Jim,

If you had access as an admin, would you be able to take a look? If its ok for you to do this, I can ask my managers to let me to give you  permission.

 

Regards and thanks,

Ken

0 Kudos
Revenera Moderator Revenera Moderator
Revenera Moderator

Re: Having issue trying to set public key again

Jump to solution

Sure Ken,

I can try uploading a public key on my end if you give me access to your Production Environment.

Thx,

Jim

0 Kudos
Intrepid explorer

Re: Having issue trying to set public key again

Jump to solution

Thanks Jim! I will contact my managers to get permission to grant it.

0 Kudos
Intrepid explorer

Re: Having issue trying to set public key again

Jump to solution

Hi Jim,

You should have an account now and have gotten the email. Are you able to upload my Public Key from UAT to production?I would like to look at your postman command to do this. I thought that mine was functional, per our conversation in October. Not sure why I get error 405 now in both UAT and prod environments.

Thank you so much for what you do!

Regards,

Ken

0 Kudos
Revenera Moderator Revenera Moderator
Revenera Moderator

Re: Having issue trying to set public key again

Jump to solution

Hi Ken,

I was able to upload my Public key to your PROD environment.   Understood this can be a bit confusing,  you actually want to upload the Public Key to FlexNet Operations as opposed to the Notification Server (the Notification Server retrieves the Public Key from FlexNet Operations).  To solve your problem use the URL below:

https://flexNNNN.flexnetoperations.com/flexnet/operations/api/updates/update-authorization-key

Please try it out with your Public Key.

Thanks,

Jim

0 Kudos
Revenera Moderator Revenera Moderator
Revenera Moderator

Re: Having issue trying to set public key again

Jump to solution

Hi Ken,

Please note I edited my previous post.  The correct URL to upload the Public Key to FNO is:

https://flexNNNN.flexnetoperations.com/flexnet/operations/api/updates/update-authorization-key

Thanks,

Jim 

Intrepid explorer

Re: Having issue trying to set public key again

Jump to solution

Hi Jim,

That URL does work.

Thank you for helping on a Saturday !!!!!

You are awesome Jim!

View solution in original post

0 Kudos
Intrepid explorer

Re: Having issue trying to set public key again

Jump to solution

It may help for the User Manual publishers to add URL information to the Update Signing Key REST API.

0 Kudos