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Summary

When attempting to adopt a device from the beacon, you may encounter the following stub error during the policy download attempt: <ActionStatus FailureReason="" ActionStateID="8" DSVersion="9.2.3" ActionGUID="32e45dc7-8c9c-4792-bdd4-e59dd6b9ce10" DateTime="2015-01-28T16:44:04-0500"> <ActionAppliesStatusCollection> <ActionAppliesStatus DateTime="2015-01-28T16:44:04-0500" ActionStateID="9" FailureReason="[RPCCommand]|[StartServiceFailed]|The stub received bad data.

To investigate this further you should enable the following line in the beacon's etdp.trace:
+Scheduling/RemoteExecution 

Now if you re-attempt the adoption the output from the trace file should look like the following error:

2.1146, pid 1004, thread 2632 (Scheduling/RemoteExecution/Common):       error starting execution service
2.1193, pid 1004, thread 2632 (Scheduling/RemoteExecution/Common):      RPC algorithm complete (intermediate error code: -1, lastError contains: "[RPCCommand]|[StartServiceFailed]|The stub received bad data.
2.1195, pid 1004, thread 2632 (Scheduling/RemoteExecution/Common):      Failed to execute with RPC algorithm
2.1195, pid 1004, thread 2632 (Scheduling/RemoteExecution/Common):     Set timeout to 3600 seconds
2.1196, pid 1004, thread 2632 (Scheduling/RemoteExecution/Common):     Attempting execution using TCP algorithm
2.1196, pid 1004, thread 2632 (Scheduling/RemoteExecution/Common):      Found winsock version: 1.1
3.1222, pid 1004, thread 2632 (Scheduling/RemoteExecution/Common):      Socket error whilst connecting: 10061
3.1223, pid 1004, thread 2632 (Scheduling/RemoteExecution/Common):      Failed to connect to remote server
3.1224, pid 1004, thread 2632 (Scheduling/RemoteExecution/Common):      TCP algorithm complete (intermediate error code: -1, lastError contains: "[TCPCommand]|[WinsockError]|10061")
3.1224, pid 1004, thread 2632 (Scheduling/RemoteExecution/Common):      Failed to execute with TCP algorithm



Other symptoms may include successful adoption from the Inventory Manager server.

Cause

The stub error is referring to the length or complexity of the policy file name that the agent is attempting to download.

Resolution

The resolution is to create a shorter or simpler policy file name. After changing the policy file name to something simple the download should be successful.
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Version history
Last update:
‎Jan 30, 2019 01:27 AM
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