Summary
The Inventory Manager database is growing in size, what could be the cause?
Symptoms
When reviewing the Inventory Manager database this grows after each compliance import by a large amount, what could cause this?
Cause
There main factor that could cause the database to grow in size could be if file evidence is enabled, this pulls in each file located on an inventory device, if there is a large number of devices there will be a large number of records moved into the Inventory Manager database.
The Inventory Agent by default scans the Windows directory by default which contains a large number of files that are unnecessary for recognition.
The following query can be used to identify which database tables have the largest amount of data in, this needs to be ran on the Inventory Manager database.
SELECT
t.NAME AS TableName,
s.Name AS SchemaName,
p.rows AS RowCounts,
SUM(a.total_pages) * 8 AS TotalSpaceKB,
SUM(a.used_pages) * 8 AS UsedSpaceKB,
(SUM(a.total_pages) - SUM(a.used_pages)) * 8 AS UnusedSpaceKB
FROM
sys.tables t
INNER JOIN
sys.indexes i ON t.OBJECT_ID = i.object_id
INNER JOIN
sys.partitions p ON i.object_id = p.OBJECT_ID AND i.index_id = p.index_id
INNER JOIN
sys.allocation_units a ON p.partition_id = a.container_id
LEFT OUTER JOIN
sys.schemas s ON t.schema_id = s.schema_id
WHERE
t.NAME NOT LIKE 'dt%'
AND t.is_ms_shipped = 0
AND i.OBJECT_ID > 255
GROUP BY
t.Name, s.Name, p.Rows, a.total_pages
ORDER BY
a.total_pages DESC,t.Name
If file evidence is the cause of growth in the database the "SoftwareFile" table will be at the top of the returned results and will be larger than any other values returned.
Resolution
FlexNet Manager Suite 2015 R2 SP4 Inventory Agent has been updated to not scan the Windows directory by default.
Additional Information
The reference number assigned to this issue is "FNMS-30699".