'Synchronize assigned user with calculated user' is not working

'Synchronize assigned user with calculated user' is not working

Summary

In FNMS System Settings > Inventory, you have selected the 'Synchronize assigned user with calculated user' option, but the assigned user is not being populated with the calculated user automatically.

Symptoms

In FNMS System Settings > Inventory, you have selected the 'Synchronize assigned user with calculated user' option. With this option, when the calculated user is updated for a device, the assigned user is also updated and this is a one-way relationship: changes to the assigned user do not affect the calculated user.  Despite the option being enabled, the assigned user is not being populated with the calculated user automatically.

Cause

This is caused by the User.xml writer referencing a wrong SettingID from the ComplianceTenantSetting_MT table. It is reverencing SettingID = 67 when it should be referencing 66.

Steps To Reproduce

Enable the 'Synchronize assigned user with calculated user' and run a Compliance Import. You will notice the Assigned User value is not changing.

Workaround

Please open the following file in a text editor:

%ProgramData%\Flexera Software\Compliance\ImportProcedures\Inventory\Writer\User.xml

Locate and change the following lines:


SELECT @AssignedUserSync = CASE ISNUMERIC(SettingValue) WHEN 1 THEN CONVERT(bit, SettingValue) ELSE 0 END FROM dbo.ComplianceTenantSetting WHERE SettingNameID = 67 -- 'RecalculateAllCalculatedUsersNextImport'

And:

UPDATE dbo.ComplianceTenantSetting SET SettingValue = '0' WHERE SettingNameID = 67 -- 'RecalculateAllCalculatedUsersNextImport'

In both lines, please change the 67 (highlighted in red) to 66 and save the file.

The next Compliance Import should now update the Assigned User to the same value as the Calculated User.

Additional Information

If you are using FlexNet Manager Suite Cloud, please log a support case and if applicable, we will make the above changes.

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Comments

Hi,

is this fixed in 2019 R1/R2 ?

From reporting that I can see, this problem is not showing up as being fixed in either the 2019 R1 or R2 release.

Be aware that the resolution described in this article will only be possible to apply with FlexNet Manager Suite On-premises; the resolution described will not be possible with FlexNet Manager Suite Cloud.

Is there a fix for this for FNMS Cloud?

@WStephans unfortunately I can't see any plan to fix this on FNMS Cloud (yet). You can log a ticket to Flexera Support to get the workaround applied for your organization.

Cheers, Kent

@kent-au actually I raised a ticket and Flexera issued a hot fix and they are now syncing as expected.

Hi ,

Where should this setting should be replaced with 66 is it in the Batch server/Beacon or both.

 

As @WStephans mentioned, there should be a hotfix available. Is fix already integrated in FNMS 2020 R1?

@dennis_reinhardt - in @WStephans' case the fix was actually a configuration change made in the backend of FlexNet Manager Suite Cloud, which the Flexera Support team was able to arrange. For FlexNet Manager Suite On-premises, the workaround described in this article stil applies to the 2020 R1 release.

Hi All,

we are experiencing some issues as well on this topic.

Do you know how often this syncro runs? Once in a week?

Thanks and regards,

Valeria 

@vmarinaro - when it is working, the synchronization would normally occur daily. However obvious if the problem described in this article has not been fixed on your system then the synchronization would never occur.

I just applied the fix on two 2020 R1 environments.

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Last update:
‎Jul 10, 2020 04:46 AM
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