cancel
Showing results for 
Search instead for 
Did you mean: 

Is FlexNet Manager for Engineering Applications 2016 R2 compatible with JDBC driver 6.0 or above?

Is FlexNet Manager for Engineering Applications 2016 R2 compatible with JDBC driver 6.0 or above?

Summary

Is FlexNet Manager for Engineering Applications 2016 R2 compatible with JDBC driver 6.0 or above? Is it recommended to use the a newer version of the driver other than what is bundled with the install?

Synopsis

Is FlexNet Manager for Engineering Applications 2016 R2 compatible with JDBC driver 6.0 or above? Is it recommended to use the a newer version of the driver other than what is bundled with the install?

Discussion

In principle, as long as the JDBC driver is compatible with the version of Java that is running (Java 8 in your instance), then there should be no problem. To date, we have not observed an issue in other Java applications when updating a JDBC driver it is JVM compatible with.

With reference to the SQL server JDBC driver chances are it is likely compatible, but is not recommended as it hasn?t been tested by engineering. According to the Microsoft compatibility matrix, the bundled version supports the same databases as the latest versions so there is no disparity there. So unless updating the driver solves a specific bug or performance issue, then it is recommended to refrain from updating as there is a possibility of a regression issue arising.
Was this article helpful? Yes No
No ratings