cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Summary

Incorrect BeaconUID causes BeaconStatus data not to be linked to the beacon and updated in the WebUI.

Symptoms

The BeaconUID is used to link the beacon status files to the relevant Beacon in the database, this data is used to update the status of the beacon and confirm what tasks have been handled and completed by that particular beacon.

If the BeaconUID is not consistent in the registry and in the status files the status data could be uploaded but not linked to a beacon.


Cause

This issue is caused when the Inventory Beacon is installed using the steps outlined in the "Unattended Installation of Inventory Beacons" section of the online help, the BeaconUID is set in the registry during the install process, the BeaconEngine service is then started, the value is then updated from the config file but the service is not restarted to pickup the new value. This causes the initial start of the BeaconEngine service to use an incorrect BeaconUID.


This issue has been assigned the following reference number "FNMS-31272" and is currently scheduled for review.


Steps To Reproduce

-Install the inventory beacon using the steps outlined in the online help "Unattended Installation of Inventory Beacons".

-Verify the BeaconUID in the registry location " HKLM\SOFTWARE\WOW6432Node\ManageSoft Corp\ManageSoft\Common". This is the 64 bit registry location.

-Review the files that are uploaded to the central server, for example the bstat files contain a ServerUID, this should match the value in the above registry location, the default location on the Inventory Beacon is as follows "C:\ProgramData\Flexera Software\Incoming\BeaconStatus".

Workaround

Once the Inventory Beacon has been installed restart the BeaconEngine service, this will re-read the registry location and detect the new BeaconUID.
Was this article helpful? Yes No
No ratings
Version history
Last update:
‎Dec 14, 2018 01:09 AM
Updated by: