How to set a manual reconcile timeout

How to set a manual reconcile timeout

Process

You can set a manual timeout using the following process:
  • Open the registry on the FNMP server
  • On 32bit systems - Navigate to [HKLM\Software\ManageSoft Corp\ManageSoft\Compliance\CurrentVersion]
  • On 64bit systems - Navigate to [HKLM\Software\Wow6432Node\ManageSoft Corp\ManageSoft\Compliance\CurrentVersion]
  • Create, or amend, the below registry key
    • Type: REG_DWORD
    • Name: CommandTimeout
    • Value: Decimal value for seconds (eg: 28800 = 8 hours)

This value can be changed as required. In relation to time, 14,400 seconds equates to 4 hours and 28,800 seconds is 8 hours, etc.
 
The next time you re-run the compliance import it will use the new timeout value.

 

Uses

If Your recocile is failing with a timeout error,  Quite often in the EvidenceAlerts, or ApplicationAlerts, steps then you can change the timeout period. Your first step should be to double the timeout, or as close to doubling as you can get. The idea here is to get the reconciliation running to completion. Support can then review the logs , see what step is running long and then work on rectifying that. In time you should be able to return the timeout to more normal levels

Labels (2)
Was this article helpful? Yes No
100% helpful (1/1)
Comments

Hi Team, 

 

I have 28800 timer set as mentioned still facing the same error. Can we increase more the timing or is there any other way to resolve this error ? 

Please guide

@samirdivan - Are you sure that you made the Registry change correctly and that you made the change on the Batch Process server and not a different FlexNet Server (application, database, beacon, etc.)

@kclausen 

 

Hi Sir, 

My senior is already made this things as mentioned above in solution. 

Still I am facing the error. 

Monday - Failed due to timeout error

Tuesday - successful

Wednesday "- Failed due to timeout error

 

  • Open the registry on the FNMP server
  • On 32bit systems - Navigate to [HKLM\Software\ManageSoft Corp\ManageSoft\Compliance\CurrentVersion]
  • On 64bit systems - Navigate to [HKLM\Software\Wow6432Node\ManageSoft Corp\ManageSoft\Compliance\CurrentVersion]
  • Create, or amend, the below registry key
    • Type: REG_DWORD
    • Name: CommandTimeout
    • Value: Decimal value for seconds (eg: 28800 = 8 hours)

@samirdivan - increasing the timeout won't necessarily stop timeout errors from occurring. That could be because whatever process is timing out is still running longer than the timeout you have configured, or because the timeout on the particular process you're running is controlled by a different timeout setting from the setting discussed in this article.

From your description it sounds like it may be appropriate to dig into the particular process that is timing out and consider if anything can be done to make it run faster instead of just increasing the timeout setting. If some insight from other people may help you with this, feel free to post over in the FlexNet Manager forum.

Version history
Revision #:
1 of 1
Last update:
‎Jun 26, 2020 06:58 AM
Updated by:
 
Contributors