cancel
Showing results for 
Search instead for 
Did you mean: 

Error "java.lang.NullPointerException" when opening FlexNet Manager for Engineering Applications Report Designer

Error "java.lang.NullPointerException" when opening FlexNet Manager for Engineering Applications Report Designer

Summary

Error "An unknown error has occurred. See the FlexNet application log for details. (Error: java.lang.NullPointerException)" displays when opening Report Designer.

Symptoms

When opening FlexNet Manager for Engineering Applications Report Designer from the Flexnet Manager UI, a message pops up saying "An unknown error has occurred. See the FlexNet application log for details. (Error: java.lang.NullPointerException)".

User-added image


The log shows messages similar to the following:

2016-09-01 22:31:09,534 ERROR [manager.services] [default task-29] Failed to invoke the API via servlet
2016-09-01 22:31:09,534 ERROR [manager.services] [default task-29] Failed to invoke the API via servlet
2016-09-01 22:31:09,535 ERROR [plt.actions] [default task-29] Failed to perform the operation
java.lang.NullPointerException
at com.flexnet.reporting.biz.BizReportService.countAllReportConfigurations(BizReportService.java:2623)
at com.flexnet.reporting.biz.BizReportService.checkIfRemoteReportingUp(BizReportService.java:263)
at com.flexnet.web.reporting.actions.ReportingBaseAction.doApplicationWork(ReportingBaseAction.java:116)
at com.flexnet.web.platform.actions.BaseAction.doActionWork(BaseAction.java:434)
at com.flexnet.web.platform.actions.BaseAction.execute(BaseAction.java:147)
at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)

Cause

This happens in 2016 R1 version of FlexNet Manager for Engineering Application when upgrading to this version from older versions and the HTTPS ports don't match in their respective configurations for admin/reporting servers. Following is an example which shows the incorrect configuration for both admin and reporting HTTPS ports:

Flexnet Site configuration on Admin server:

User-added imageUser-added image

Flexnet Site configuration on Reporting server:

User-added imageUser-added image


Workaround

Following is a workaround to fix this issue:

1. Stop both admin and reporting servers using the command 'flexnet stop' on the command line from the respective admin or reporting installed directories, .../flexnet/manager/admin or .../flexnet/manager/reporting.

2. Run flexnet site from admin server and make changes to HTTPS port for the Reporting server HTTPS port and similarly run flexnet site from reporting server and make changes to HTTPS port for the admin server. Below is an example which corrects the HTTPS ports for both servers that were incorrectly shown in the above example:


User-added imageUser-added image
User-added imageUser-added image

Please note that the HTTPS port numbers shown above are for demonstration purpose only. Please use your own port numbers as set in your system environments.

3. Start reporting server first by typing 'flexnet start' at command line or turn on the service 'FlexNet Manager for Engineering Applications Reporting' from the Services page.

3. Next start the admin first by typing 'flexnet start' at command line or turn on the service 'FlexNet Manager for Engineering Applications Admin' from the Services page.

Was this article helpful? Yes No
No ratings