cancel
Showing results for 
Search instead for 
Did you mean: 

Error in Amazon Web Services (AWS) PowerShell Connection When Using a Proxy

Error in Amazon Web Services (AWS) PowerShell Connection When Using a Proxy

Summary

This KB article addresses the issue where, while using a proxy server, the Beacon will fail to get account details for an AWS (Amazon Web Services) inventory import. Applies to FNMS 2018 R2 On-Premise only.

Symptoms

While using a proxy server, the Inventory Beacon will fail to get the account details for an Amazon Web Services inventory import.

In the importer.log you will encounter the following error message:
[ERROR] Name resolution failure attempting to reach service in region us-east-1 (as supplied to the -Region parameter or from configured shell default).
Unable to connect to the remote server.

The region stated in this example, us-east-1, can be different and is not specific to the issue.

Steps To Reproduce

  1. Create an AWS PowerShell connection as outlined by the Online Help article 'Managing AWS EC2 Connections', ensuring all pre-requisites are in place.
  2. Select the Use Proxy check box and enter the details as directed in the article.
  3. Initiate the task and track the error in the importer.log on the Inventory Beacon located: C:\ProgramData\Flexera Software\Compliance\Logging\ComplianceReader

Resolution

To install the hotfix, you must have installed the on-premises edition of FlexNet Manager Suite 2018 R2. To download the hotfix, which is called '', follow the below steps:
  1. Login to the Product and License Center (PLC). Either access it directly or via the Customer Community Portal by selecting Downloads.
  2. Under 'Your Downloads' select 'FlexNet Manager Platform' and then 'FlexNet Manager Suite 2018 R2'.
  3. Expand 'FlexNet Manager Suite Hotfix 2018R2-01' to download 'FlexNet Manager Suite Hotfix 2018R2-01.zip'
Note: the hotfix contains a readme.txt and a PDF - please ensure you have read both before proceeding.

Workaround

N/A.

Additional Information

This applies to FNMS 2018 R2 On-Premises only.
Was this article helpful? Yes No
No ratings